View Single Post
MacDude121

 
MacDude121's Avatar
 
Member Since: Sep 22, 2010
Posts: 1,416
MacDude121 is a glorious beacon of lightMacDude121 is a glorious beacon of lightMacDude121 is a glorious beacon of lightMacDude121 is a glorious beacon of lightMacDude121 is a glorious beacon of lightMacDude121 is a glorious beacon of light
Mac Specs: Black MacBook 2.2GHz C2D, 4GB Ram - iMac G4 700MHz, 512MB Ram

MacDude121 is offline
Quote:
Originally Posted by harryb2448 View Post
Do not think so and a Quad is not cheap and in time you may well regret not putting the cash to an Intel machine. A cheaper Mini or iMac may well be the go and will run Snow Leopard and maybe Lion depending on the specs. The day of PowerPC is over sadly and if Apple follows the usual method of dropping support for an operating system two versions old, the release of Lion may well see no more support for Leopard, the last OS a G5 can run.

Support for Tiger OS X.4 ceased with the release of Snow Leopard, and as time goes by any application, games or utilities for PowerPC architecture will get scarcer.
I know. But honestly, from what I've seen there's still a good $300 jump from G5 to early intel, something I just can't afford. Besides, I've looked at the early Intel mini's that aren't too hugely out of the ballpark and their outclassed by the G5 benchmarks still. I'd rather have the extra processing power, than be able to run 10.6 and 10.7. Support may have dropped for Tiger, but I'm still running it with almost no compatability issues so far. I realize this will probably come to an end soon though. No OS can stay up-to-date forever.
QUOTE Thanks