View Single Post
nk.drozd

 
Member Since: Nov 24, 2010
Posts: 2
nk.drozd is on a distinguished road

nk.drozd is offline
Quote:
Originally Posted by kokyaw View Post
I have 20" Intel Core 2 duo iMac with 2G RAM, 250 GB hard drive.

This 'won't pass blank grey screen' scenario has happened to me for quite a few times now.

You can skipped "First Time" and "Second Time" if you don't have time to read. Please go straight to "Third Time (most recent)" section cos' I need help there!

First Time
-----------
What I had: Bootcamp Dual boot with Leopard and Vista Ultimate 32 bits
What happened: won't pass blank grey screen
Tried: pressing 'c' to boot from leopard CD, resetting PRAM, holding mac mouse to eject without success.
Story:
I finally took the mac to store and left it there for a few days till they called me up. They said they tested the hardware which was fine and said software has some issues. I went there and the guy told me to hold down that magic 'c' again while booting and it BOOTED into the leopard cd in one shot. I did a clean install of Leopard and windows.
Problem solved!

Second Time
------------
What I had: Bootcamp Dual boot with Leopard and XP Pro 32 bits
What happened: won't pass BLANK grey screen.
Tried: pressing 'c' to boot from leopard CD, resetting PRAM, holding mac mouse to eject without success, etc..
Story:
This time, I didn't take it to store. After my iMac was fixed from the first time, I did install XP Pro I got from my university (you can still see I didn't give up dual booting yet) after Vista failed on me. But this stupid grey screen came up every time again. My leopard cd was in the cd-drive which ran at the startup and then nothing happened with 'c' pressed. So I was frustated and left it like that and was using my laptop. Two days ago, I restarted my mac and wala! it booted straight into Leopard. I didn't press anything. It was MAGIC. I can't believe it.
Problem solved!

Third Time (most recent, different from above two, NEED some HELP HERE!!!!)
-----------
What I had: Bootcamp Dual boot with Leopard and XP Pro 32 bits
What happened***: won't pass the grey screen WITH AN APPLE logo***.
Tried:
0. I haven't put in my leopard CD yet. Because once I put it in, it WILL NOT come out!
1. Pressed 'X' - no response.
2. Pressed 'option' - nothing happened (this time, the apple logo disappears from the grey screen after boot up, but nothing after that)
3. Pressed 'ctrl+S'. Nothing happened (grey screen with apple)
4. Pressed 'cmd+S'. Then it booted in to a black screen and showed me some texts. I copied the last few lines below:

...
....
....
Mac framework successfully initialized
using 10485 buffer headers and 4096 cluster IO buffer headers
devfs_make_node: not ready for devices!
IOAPIC: Version 0x20 vectors 64:87
ACPI: syster state [S0 S3 S4 S5] (S3)
mbinit: done
Security auditing service present
BSM auditing present
rooting via boot-uuid from /chosen: C611669E-6047-3161-A8E6-327A8F98BEAC
Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>
FireWire (OHCI) Lucent ID 5901 built-in now active, GUID 001cb3fffe9eda40; max speed x800.
wl0: Broadcom BCM4328 802.11 Wireless Controller

Sometimes, the last two lines: "FireWire (OHCI)....." and "wl0: Broadcom...." showed up, but not always. It stucked at "Waiting on <dict....." line usually.

PLEASE HELP ME!! I don't have a car to take it to the store. I have to bother my friend again. So I want to solve it at home.

Thanks a lot!
kk
Okay, so here is the solution that i have come up with for my iMac




So, iv got the same problem, but apple store is way to far, and i don't have my license yet, so iv tried to do everything i could, and have made my computer work again.
I have 27'' iMac,3.2GHz, intel core i3, 2010. I had a boot camp windows installed on it, witch was working with no problems, so at least I could copy all of my files to external hard drive. But the fact that i had my windows work perfectly, i knew that the problem that i (we) had is not with hardware.


There is 2 DVD, that have came with my computer: one is Mac OS X install DVD, and the second one is iMac application install DVD. I have inserted the first one into my computer, and booted it of the DVD. (to boot from dvd drive, turn off your computer any way you want, then turn it back on and press opton(alt) key starting as son as you hear the apple-turn-on sound, and keep pressing it until you will see the picture of your hard drive, and then, you can press the "eject the CD/DVD" key on your keyboard. The current CD/DVD will be ejected, and you can put in the iMac OS X install DVD. Than you should wait at least a minute, you will see a new CD pic. on there, chose it and press "enter".)
After booting my computer of that DVD, you will see that grayish screen but this time wait. ( the information is loading from the DVD. It will take about 2-5 minutes, but you should wait all 10. If it doesn't work, start over with that booting thing), it will tell you, that its gonna install you a new OS, but don't worry about that. In the menu you'll see, you will have to chose a language, so do it. After that, you will see a regular Mac top screen bar, with something like """apple sign", "mac OS installer", bla bla bla... , and finally "utilities"" on it. We need the utilities thing. Click it, and it will give you different utilities. The one that i have used,(and probably you should) is "Disk utility". Open it, and choose the hard drive with the installed Mac OS on it (probably it will be named Macintosh HD. Then, click the "verify disk", it should take some time, and after its done (hopefully saying that you have tons of errors and problems with it), click "Repair Disk".Hopefully it will repair it. Then you can run the "verify the disk permissions" test, and then "repair disk permissions".
That the thing that have SAVED my iMac. So now just shut it down by pressing the power button, and turn it on as regular, and it MUST work!!!!

If it doesn't, you van run some other tests, (for example a hardware test that is on the other DVD, just boot for it). But if it DOES work, well… we are happy people now, with working Macs .
i am very new to the mac, and i am very happy (and proud) that i have solved this problem, zoo please email me, if it worked for you!! nk.ddrozd@gmial.com, or to my mailbox on mac-forums.com
QUOTE Thanks