View Single Post
techevodmu

 
Member Since: May 18, 2010
Posts: 2
techevodmu is on a distinguished road

techevodmu is offline
Hi all,

Basically, am trying to install ettercap-ng from source on mac os 10.6.3...

i have all the dependencies from macports, but if i install ettercap from there, there are no plugins...which just makes it tcpdump pretty much.


i need the plugins for university work, so installing from source seems my only option..

below is the out put i get from the make command (configure works fine)

Code:
Making all in man
make[1]: Nothing to be done for `all'.
Making all in share
make[1]: Nothing to be done for `all'.
Making all in include
make  all-am
make[2]: Nothing to be done for `all-am'.
Making all in include
make  all-am
make[2]: Nothing to be done for `all-am'.
Making all in src
Making all in os
make[2]: Nothing to be done for `all'.
Making all in interfaces
Making all in daemon
make[3]: Nothing to be done for `all'.
Making all in text
make[3]: Nothing to be done for `all'.
Making all in curses
Making all in widgets
if gcc -DHAVE_CONFIG_H -I. -I. -I../../../../include    -O2 -funroll-loops -fomit-frame-pointer -Wall -I/usr/include/pcap      -g -O2 -MT libwdg_a-wdg.o -MD -MP -MF ".deps/libwdg_a-wdg.Tpo" -c -o libwdg_a-wdg.o `test -f 'wdg.c' || echo './'`wdg.c; \
	then mv -f ".deps/libwdg_a-wdg.Tpo" ".deps/libwdg_a-wdg.Po"; else rm -f ".deps/libwdg_a-wdg.Tpo"; exit 1; fi
wdg.c:759: error: conflicting types for ‘wdg_set_color’
wdg.c:82: error: previous declaration of ‘wdg_set_color’ was here
wdg.c:786: error: conflicting types for ‘wdg_init_color’
wdg.c:81: error: previous declaration of ‘wdg_init_color’ was here
wdg.c:794: error: conflicting types for ‘wdg_screen_color’
wdg.c:83: error: previous declaration of ‘wdg_screen_color’ was here
make[4]: *** [libwdg_a-wdg.o] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

and this is the outcome of command make install

Code:
Making install in man
make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/man/man5" || /bin/sh ../mkinstalldirs "/usr/local/man/man5"
mkdir -p -- /usr/local/man/man5
mkdir: /usr/local/man/man5: Permission denied
make[2]: *** [install-man5] Error 1
make[1]: *** [install-am] Error 2
make: *** [install-recursive] Error 1
anyinput would be cool,

cheers

techevodmu
QUOTE Thanks