View Single Post
editionfive

 
Member Since: Apr 19, 2010
Posts: 3
editionfive is on a distinguished road

editionfive is offline
Hi, Iím hoping someone could shed some light and let me know how to fix this problem. The My Book Studio Edition II that Iíve been using for 5 months (only) suddenly wouldnít mount on my PowerBook G4 (Mac OSX 10.4.11). I tried using Disk Utility and I could see the drive and the icon is dim. When I clicked ďmountĒ it still wouldnít mount, the drive is still showing dim. The WD driver manager also showing the drive in good status and good condition on the menu bar and has the green light. The power light/LED status and activity lights seemed acting normal, it goes in & out when I tried to mount it. And I could hear the sound that normally when the drive is landed on the desktop. However, itís not there. I tried using different cable - Firewire 400, 800 and USB cable and it still wouldnít work.

I donít know if itís caused by the new Macbook Pro (latest Mac OSX Snow Leopard) I recently purchased. The whole problem started when I plugged the external MyBook HD to the new Macbook Pro to transfer some files, it was working, but then when I plugged it back to the Powerbook G4, itís just not showing. I then tried to plugged it again to the new Macbook pro, not showing either. I have the My Book HD configured in RAID 1 with no password at the moment.

I also bought another My Book Studio Edition II HD two weeks ago (donít know now if this is a good idea now!!). Iím using it with the Macbook Pro with Time Machine. At the moment seems to be working ok. But Iím not dare to plugged it in to the Powerbook G4, just in case it disappear on both laptops. I apologise for the long posting, but I think Iíve coveredd all the issues that I encountered. I hope the drive will come back so I can get back all the data (900MB) in it.

Thanks so much for your help in advance.
QUOTE Thanks