View Single Post
WintersFury

 
Member Since: Sep 30, 2009
Location: NY
Posts: 18
WintersFury is on a distinguished road
Mac Specs: MBP 13 - 2.26 C2D - 9400m - 2gb RAM - 500gb 7200.4 Seagate

WintersFury is offline
Not sure if this should have gone into the Windows forum, if I should have put it there I'm sure a mod will move it though.

I recently decided to put one of my copies of Win7 on my 13" MBP and well... I used the disc that came with the computer and it put tons of drivers that are not for my laptop. Like Intel and ATI drivers on an NVidia based notebook... But not too big a deal, I can just uninstall that stuff later.

Then I run the 3.1 update for Win7 32bit and well... Either it did something to my password or remapped the keyboard or something cause my password no longer worked to log in.

So I decided to try and just install the drivers I need this time... But now things like the keyboard illumination and backlight adjustment don't work. The keyboard, display and other drivers don't install properly...

So it seems like one of the bootcamp programs unfortunately makes all the drivers and such work properly? Not sure how they pulled that one off, but I'm at a loss as to what else could be causing it at this point.


Soooo... Anyone have any advice for installing the drivers yourself? Or getting the 3.1 update not to kill my install again?

I figured it would be a bit... easier as Apple likes to say their stuff is. But I shoulda known buying a Mac to run Windows wasn't the best idea out there
QUOTE Thanks