PDA

View Full Version : Problem started today



MickyTeddy
12-02-2017, 01:37 PM
I am the only user of my MacBook Air. Today all off a sudden when I switched on it asked for account verification.
This is the first time it has happened.
It is annoying to have to put in my name and password each time. I have arthritis so lots of typing is painful.
The - sign next to the user account is not illuminated so I am unable to delete the guest account.
It has never been used--ever. Any ideas?
I looked up it as a topic but it gave me 2 file names that I cannot locate on my computer.
Thanks in advance!!!

cradom
12-02-2017, 03:09 PM
I don't think you can delete the Guest account but you can turn it off. Click the little orange lock at the bottom of the window. It will ask for your password. Input it. Now click on the Guest account. Make sure everything is UNchecked there.
That - under the Login Options is for the startup items, not the accounts.

MickyTeddy
12-03-2017, 06:05 AM
I have clicked on the padlock and there is nothing ticked in the alt user box nd the padlock is now on to no avail. It is just inconvenient. I have been a Mac user for 27 years and have never experienced this before

MacInWin
12-03-2017, 06:19 AM
nd the padlock is now on to no availWhat does that mean, exactly? Is it no longer unlocking when you provide an admin password? In System Preferences/Users & Groups, click on Login Options and unlock the padlock, then make sure that automatic login is not set to "Off." I believe Apple now sets that to a default of being ON for all users.

MickyTeddy
12-03-2017, 06:36 AM
The padlock where the users and groups are, I was advised to unlock it and the relock it when I had unchecked the alternative user but it only asks for a admin password on my primary account.

nickyr
12-03-2017, 07:56 AM
you can disable the need to sign in by going to:

>system preferences
>security & privacy
>general
>uncheck the box requiring a password after sleep
>uncheck the box "disable" automatic log-in

But these steps would leave your Mac open to anyone who could get their hands on it. It's not something I would advise but if you're happy to do so....

toMACsh
12-03-2017, 08:49 AM
I have both of those unchecked, but my Mac is a Mini, so it does not travel. I don't need it to be that secure.

MacInWin
12-03-2017, 09:23 AM
The padlock where the users and groups are, I was advised to unlock it and the relock it when I had unchecked the alternative user but it only asks for a admin password on my primary account.That is correct. It asks for an admin account password and from there one can do whatever is needed for all accounts. It doesn't ask for a separate password to enable changing each account.

If you have the boxes set as nickyr says to do, try a reboot of the system to see if the change has been applied.

MickyTeddy
12-03-2017, 03:28 PM
Sadly this hadn't worked.
The following are not visible

>uncheck the box requiring a
password after sleep
>uncheck the box "disable" automatic
log-in
=20
I believe this possibility began after downloading the Apple security patch?
MickyTeddy

cradom
12-03-2017, 06:01 PM
Your preference pane doesn't look like this? I'm running High Sierra with the latest security patch.