PDA

View Full Version : Keyboard buttons not working



spurs73spurs
06-15-2017, 09:38 AM
Just wondering if anyone could please help me. My keyboard has some buttons that are not working. I went and replaced the keyboard with a brand new one yesterday and the same buttons are not working on the new one as well. Just wondering if there is a setting that may have changed.

Thank you

pigoo3
06-15-2017, 10:19 AM
Sorry have no idea what sort of computer you are referring to. Could be a desktop keyboard...could be a laptop keyboard. And since the thread was posted in the "Switcher Hangout" area (not the proper place)...can't make a firm guess based on the topic area. I'm guessing you're talking about an Apple notebook computer...please confirm.

Thanks,

- Nick

spurs73spurs
06-15-2017, 11:00 AM
My apologies mate. I am talking about my Mac desktop the keyboard is now a new magic keyboard. there is a block of 9 keys that do not work, and all the others do work.
Sorry for posting in the wrong spot.

Slydude
06-15-2017, 03:44 PM
What, if anything, happens when you press one of the keys that doesn't work?

pigoo3
06-15-2017, 05:02 PM
My apologies mate. I am talking about my Mac desktop the keyboard is now a new magic keyboard. there is a block of 9 keys that do not work, and all the others do work.
Sorry for posting in the wrong spot.

Ahh...I was wrong. It WAS a desktop keyboard.;)

- Nick

chscag
06-15-2017, 08:41 PM
Turn on the keyboard viewer in System Preferences, Language & Region by selecting "Show input menu in menu bar". When the small flag appears in the menu bar, click on it and then select "Show Keyboard Viewer". Now... press on those keys that are not working and tell us what happens in the keyboard viewer.

Slydude
06-15-2017, 08:47 PM
Turn on the keyboard viewer in System Preferences, Language & Region by selecting "Show input menu in menu bar". When the small flag appears in the menu bar, click on it and then select "Show Keyboard Viewer". Now... press on those keys that are not working and tell us what happens in the keyboard viewer.
Great idea. I never thought of doing that.

spurs73spurs
06-16-2017, 01:13 AM
All sorted, thank you all for your help.
I had to go to System Preferences, Accessability, Mouse & Trackpad and unclick Enable Mouse keys. Not sure how thats been turned on as I do not have a track pad and rarely go to System Preferences.

pm-r
06-16-2017, 09:41 PM
Great idea. I never thought of doing that.


Gee whizz Slydude, the Admins are going to knock you down to only being allowed a nine gallon hat for not knowing that!!

It's been a standard keyboard test method for years now and has also been known to be used to type an emergency email using only the mouse!! :o





- Patrick
======

pm-r
06-16-2017, 09:46 PM
Not sure how thats been turned on as I do not have a track pad and rarely go to System Preferences.


Sometimes the default to enable the feature was set to be On, and I believe it was something like five presses on the option button would enable the feature. So, just maybe…





- Patrick
======

Slydude
06-17-2017, 12:39 AM
Gee whizz Slydude, the Admins are going to knock you down to only being allowed a nine gallon hat for not knowing that!!

It's been a standard keyboard test method for years now and has also been known to be used to type an emergency email using only the mouse!! :o

- Patrick
======
That's a big improvement over the dunce cap I've been wearing for forgetting the date of the WWDC keynote. :Blushing::Oops: We're in negotiations. I'm shooting for a 9.5 gallon hat.:)