PDA

View Full Version : Turn off iCloud



samwise2u
05-06-2017, 10:59 PM
I would like to turn off iCloud.

Thing is in Finder it shows all my documents on iCloud Drive and zero in Documents.

1. How do I turn off iCloud? System Preferences\iCloud and uncheck everything?
2. What happens to my documents on iCloud Drive? Hopefully :Cool: iCloud Drive\*.* ----> Documents

chscag
05-06-2017, 11:49 PM
Welcome to our forums.

Before doing anything, make a copy of all your documents that are in iCloud and place them in a folder separate from your Documents folder. That is very important otherwise you may lose all your documents when reverting back! So, do that first.

After making the copy as I stated above, go to System Preferences, iCloud, and select iCloud drive options. Then remove the check from the box that says "Desktop and Documents Folder". Leave System Preferences and reboot your machine. After booting back up, you can copy all your documents from that separate folder back to your documents folder as you had them before.

Be very careful about making that backup first! ;D

samwise2u
05-07-2017, 12:30 AM
I created a new folder in Downloads named Test. Clicked iCloud Drive and copied/pasted 3 folders to Test. Opened System Preferences, iCloud, clicked on options next to iCloud Drive, and "Desktop and Documents Folder" (Note 1) was ALREADY unchecked. Exited System Preferences, rebooted. iCloud Drive still shows files as does Test.

Note 1: Other options are checked. Preview.app, TextEdit.app, Mail.app and System Preferences.app. Weather.app is not.

Sound right?

While we're at it...Tried to make Test under Favorites but could not solve the mystery. Asking for a clue.

Rod Sprague
05-07-2017, 01:41 AM
It never ceases to amaze me at the way people can interpret instructions. After years of part time work on a support desk I realise there are at least 2 ways of interpreting anything but people are so creative and english is often ambiguous.
So lets tackle the last point first.
Drag the Test folder out of the downloads folder onto the desktop. Open it and a finder window. Drag the 3 folders in Test to your Documents Folder on the sidebar of the finder window.
So now you should have copies of your 3 folders in your Documents folder. Check each one and make sure contents are complete.
Now you have said that in System Preferences > iCloud > iCloud Drive Options that the option for Desktop and Documents Folders is unticked. Bear in mind anything ticked in this box will be stored and or backed up in iCloud.
Personally I only have Mail, Reminders and System Preferences ticked.
Note at the Bottom of this little window is another tick box which says Optimize Mac Storage. read the description of this action. If you have adequate space you might like to tick this.
Now shut down and reboot your Mac.
Open a word processor eg. Pages or MS Word and create a short document. Select Save As and in the dialogue box that pops up select Documents as the destination to save to.
Look in the Documents folder and it should be there. Check that it is not in the iCloud Drive folder.
That should do it.

samwise2u
05-07-2017, 01:14 PM
Note at the Bottom of this little window is another tick box which says Optimize Mac Storage. read the description of this action. If you have adequate space you might like to tick this.

It was and still is ticked. Have plenty of space on HD.

Everything else was accomplished and the new file was saved in the original Documents folder.

Thank you for your time and help.

Rod Sprague
05-07-2017, 09:18 PM
Great, sounds like you have solved it.