PDA

View Full Version : Samsung 850 EVO for I Mac 27" 2010



FERDINAND
04-13-2017, 07:51 PM
Hi,

I read articles and watches tutorials on swapping out the HD for a SSD in an I Mac 27' mid 2010. One of the articles used a Samsung 850 EVO 1TB. So I purchased SSD and an OWC thermostat and completed the installation. I had decided to use Time Machine to reboot. However - nothing happened. I then reinstalled the HD and tried cloning the SSD. this time following message appeared.
"The disk you installed was not readable by this computer"
So my question,
- Do I have a duff SSD?
- Is this SSD incompatible for this machine?
- Does the SSD need to be formated in any way?

Looking forward to clarification.

Thanks and Best Regard
Ferdinand.

chscag
04-13-2017, 08:37 PM
Welcome to our forums.

How did you clone the original HD to the Samsung EVO SSD? What did you use to do the cloning?

FERDINAND
04-14-2017, 12:04 AM
Thanks for the welcome,

I didn't manage to perform any cloning. I re-instilled the HD hoping I could clone the SSD using Carbon Copy Cloning via SATA - USB. However, as soon as I connected the SSD the following message came up on screen.

"The disk you installed was not readable by this computer"

It seems my computer does not like this SSD.

harryb2448
04-14-2017, 12:10 AM
Sounds like you need to format the SSD Mac OS Extended (Journaled). Did an additional piece of that message give the 'Initialise' option?

Also the Samsung EVO is a 6Gbps SATA III device and your iMac is SATA II 3Gbps. We have had threads on bhere about problems between Samsung EVO's and 2009 model Macs as the Samsung does not want to be backwards compatible.