PDA

View Full Version : 'Photos' - no sound on video



Terabyte
04-10-2017, 11:50 AM
I have some videos in Photos that were taken on my old Canon PowerShot at 640 x 480 and there is no problem with the sound.

I took some videos yesterday on Fujifilm Finepix at 1920 x 1080 and there is no sound. Today I tested videos at 1280 x 720 and 640 x 480 on the Fuji and there is still no sound.

The camera is 3 years old, so I did not expect to have problems with using Apples Photos. How can I get sound on my Fuji videos please?

Raz0rEdge
04-10-2017, 12:27 PM
Do you have sound if the play the videos on the Fuji camera? The file is likely in MOV format, have you tried playing that in Quicktime Player or VLC?

Terabyte
04-10-2017, 01:23 PM
Yes, there is sound on the Fuji camera. I have deleted everything except the last one which is 640 x 480. I do not have Quicktime or VLC. I will do have GIMP, so will see if that has video option and will get back to you

Raz0rEdge
04-10-2017, 01:33 PM
QuickTime is part of macOS, so you already have it. VLC is a good media player to play a wide variety of files.

Terabyte
04-10-2017, 03:19 PM
QuickTime will not open. I will have to spend more time on this tomorrow as it is pm here and I need to work on the videos even without the sound. I will let you know it I get QT or VLC. Thanks

Terabyte
04-11-2017, 01:57 PM
Do you have sound if the play the videos on the Fuji camera? The file is likely in MOV format, have you tried playing that in Quicktime Player or VLC?

The file with my FujiFilm is .MOV. Can I convert it to something that Photos will accept? If yes, what is the best format for it please

Raz0rEdge
04-11-2017, 01:59 PM
MOV has traditionally been a QuickTime format which is a Apple designed one and as such Photos should be completely fine with it. If you want to convert it, you can use a program like Handbrake (https://handbrake.fr/) to re-encode it to something else.

Terabyte
04-11-2017, 02:21 PM
All of the FujiFilm videos are in .MOV format and the video is fine except they all have no sound. My old Cannon is .AVI format and I can see and hear the videos.

Is there something within Photos that can be tweaked?

Raz0rEdge
04-11-2017, 02:52 PM
Did you try VLC/QT to see if it would play the MOV files with sound?

Terabyte
04-12-2017, 09:25 AM
Cannot get Quicktime on my Macbook Pro w/retina. Icon is there but it does not open. I downloaded VLC but the videos on that too do not have sound.

Terabyte
04-13-2017, 07:11 AM
I took 2 new videos with the Fuji camera. One 640x480 and the other at 1920x1080. They both playback on the camera. I then tried it on my Windows 10 laptop using Windows Movie Maker and the sound is on the 640 video but not the 1920.
I again tried them in Photos and no sound on either.

IWT
04-13-2017, 09:34 AM
@Terabyte

I am as confused as my colleagues:Grimmace:

Two things:

1. You have a new Mac and Quicktime is part of the OS, as previously stated. May I presume that you went into Applications and clicked on Quicktime? There is some other problem if it does not open.

2. Tedious though it may be, can you try importing your video(s) into iMovie and test the sound on "Play"?

In case you are not familiar with iMovie (it's part of your OS), here's a step by step account of how to import a video from your camera: http://www.wikihow.com/Add-a-Video-on-iMovie

I'd appreciate your trying this if you have the time.

Ian

Terabyte
04-16-2017, 10:23 AM
Sorry for the confusion.

1. I did go into Applications for QuickTime and it did not open. I did a lot of searches and in the end just thought I would try a download and it is now working.

2. My Macbook Pro 2015 did not come with iWorks or iMovie. Even though it is only 15 I decided that I did not need it because I very rarely take videos. I have only taken about ten in many, many years. When my friend gets back from her vacation, I will see if she has the App and will try it on her Mac and will get back to you.

What I have tried so far for .MOV & .M4V:

- Apps with no sound = Photos, Quicktime, VLC, Windows 10 laptop MovieMaker 1920x1080
- Apps with sound = FujiFilm camera, Google Video, Windows 10 laptop MovieMaker 640x480

I just want to be able to see and hear my videos in Photos and eventually on my Mac with a basic editing App which will be iMovies if it works.

Does above make sense?

ferrarr
04-16-2017, 09:53 PM
If you purchased the Mac new, you should be able to get iMovie, GarageBand, and all the iWork apps, through the Mac App Store. Look on the Purchased page, make sure you are logged in with your Apple ID.

Terabyte
04-17-2017, 06:46 AM
I bought it from an elderly friend who had it for a few months and did not like it, so went back to Windows. I called Apple before I bought it and they said I would get the Mac with everything that came with it - as new. Yesterday I made a 'chat' call to Apple and after about an hour they gave me instructions on how to get iWorks, iMovie, GarageBand etc. Unfortunately, the instructions did not work so I will be chatting to them again. Hopefully it will work.

I will get back to all of you as soon as I have some answers

ferrarr
04-17-2017, 08:47 AM
Did you or the seller erase and format the drive? Reset it to factory settings? See this article, https://support.apple.com/en-us/HT201065.

Also, if your "elderly friend" already accepted those apps, they will be associated with his Apple ID, then you may not be allowed to get them.

Terabyte
04-17-2017, 10:48 AM
Yes, it was formatted/ reset.
According to Apple, yes his ID is associated with the apps but I think they were trying to do me a favour because I did make a call to them before I bought it and was told that I would be getting them. There probably is a log of my call with them.

ferrarr
04-17-2017, 10:52 AM
OK, good to know. A phone call is such an easy solution to some issues people have with their PC's. Apple, in my opinion, goes way out of the way to accommodate most users.

Terabyte
05-01-2017, 02:19 PM
OK, good to know. A phone call is such an easy solution to some issues people have with their PC's. Apple, in my opinion, goes way out of the way to accommodate most users.

I thought I would send a quick update. I just had a look at iMovie in my Apple Store and it was free. So I downloaded it and unfortunately there is no sound on the videos. This is all very strange and I can see no solution...