PDA

View Full Version : moving background



sandman
11-08-2016, 11:07 PM
Hello
this has been bugging me for months now, and i can't understand it or find any answer on the net
I've downloaded a lot of movies to my HD, I then mostly watch them on my flatscreen.
via a Servio.
Any way what is funny is that during some scenes the foreground is stable, but the background moves
Here is what I mean

Say the shot is in a room, and two people are talking, all of a sudden the wall will twist, move
while the two people are steady..
Like I said I can't explain it, and that does not happen at least don't think so if I run the video
on QuickTime 7

Anyone one have a thought on this?

mrplow
11-09-2016, 11:15 AM
That sounds like:
A compression issue, a local network throughput issue or the app/device that's performing the playback isn't coping.

What device/app is playing back the file?
How is your Servio streamer connected to the network?

sandman
11-11-2016, 08:12 AM
Yes Servio is running on my network... I find it interesting and funny, when watching people talking and
seeing the background moving all over, does not really make sense. You know I should have stopped the movie
and played it back on my computer with QuickTime and see if it made a difference...
Best
and thanks

mrplow
11-11-2016, 08:28 AM
Same questions I'm afraid
How is your Sergio connected to your network.
What is performing the playback of the file? How is that connected to the network?
If you can explain a little about how everything is connected to each other it may help

sandman
11-11-2016, 08:45 AM
Serviio is playing the video off of my computer over my WiFi to the Router which is hardwired to the TV
That is the only reply I can give...

And BTW these are old movies from the 30's or 40's not newer movies that might have been shot using
video equipment. So I can not see how one frame of the movie can move, that to me would be like a layered
process.

mrplow
11-11-2016, 09:05 AM
Broadly speaking, when video is digitised and compressed the algorithm looks for areas of the picture that don't change much frame to frame and applies a higher level of compression to these. A lower level is applied to fast moving things as there's more detail to be captured. That means that regardless of how the video was orginally produced you aren't displaying full frames one after another with digital video in the same way as film.

As your Servio is pushing this file across your network, pieces are arriving at your TV where these parts are re-assembled (presumbly a built in playback app), and put up on the screen.

What can often happen with wifi is that inteference, channel clash, distance, blocking due to the architecture surrounding the equipment can end up with dropped or lost packets of information that has to be resent or missed.
If this happens, the application playing back the file can struggle to put everything up on the screen correctly. It's then you can witness, jumping, tearing, smoothing and weird movement in the picture.

So there's three parts to the setup you have:
1. Your Servio box has to take the data from the hard disk and push it out across the network - I expect this will be fine.
2. Your network then has to transport this to the TV - this is likely where issues are occuring.
3. The playback app on the TV has to take the data, re-assemble it and display - not all built in apps are great at this depending on the data rate, codec used etc etc.

This kind of things are notoriously difficult to diagnose and rectify remotely but here goes.

Are you able to temporarily connect your servio to you network by ethernet and not use wifi at all? Then re-try playback.
Can you try other files?
Do you have any other application or device you can playback with (Apple TV, Fire stick etc)?

sandman
11-15-2016, 07:19 AM
Thanks, I can understand that