PDA

View Full Version : Music migrating to cloud



Northroad52
10-18-2016, 07:53 PM
I have a lot of music on my iMac, and just found out some of my albums are no longer on the hard drive, but are somehow in the cloud. It wants my Apple ID just to listen to my own music, and says I can't use it again for 90 days. My question is why are these albums no longer on my hardrive. How do you get stuff to stay where you put it and not migrate to the cloud?
We don't always have internet, and it's impossible to access the cloud without it.

KevinJS
10-18-2016, 08:04 PM
Sounds like you have signed up for Music Match, or Apple Music, whatever it's called these days.

NO idea why music that should be physically on your HDD is no longer there.

Might be worth giving it your AppleID and seeing whether the music will reinstall itself where it is supposed to be.

Rod Sprague
10-18-2016, 09:25 PM
What Operating System are you using?
Have you subscribed to iCloud Music Library?

Northroad52
10-18-2016, 10:15 PM
I'm on Mavericks and have always avoided iCloud like the plague. It just doesn't work without internet. I just got a new iphone and all of a sudden weird things are happening with my old iPad and my iMac. I don't want anything stored in the cloud.

Rod Sprague
10-19-2016, 08:06 AM
Did you create a new Apple ID for your iPhone or do you only have one. Do you use the same Apple ID for your iTunes account.
Although not a nesessity it is desirable to have one user name and password for all things Apple.
The reason I ask is because the only time you encounter the 90 day device association rule is where, well, have a look at this thread on these forums. http://www.mac-forums.com/os-x-apps-and-games/309493-90-day-itunes-device-association-rule.html
I do sympathise with your internet limitations but an iPhone can hardly be used without an internet connection of some kind.

IWT
10-19-2016, 08:11 AM
@Northroad52

My older iMac runs on Mavericks. I checked out the settings on that iMac.

If you open iTunes and go into preferences (shortcut is Cmd + comma), then General. "Show Apple Music Features" can be checked or not. If it is checked, uncheck it. It really only applies if you have a sub to Apple Music.

But make sure "iCloud Music Library" is not checked. I'm reasonably certain that your problem, as described, is linked to this feature. (equally if you had the previous iTunes Match).

I'm sure you would have said if you had an Apple Music subscription because that would create similar appearances and similar demands re your Apple ID.

Whilst in Preferences, go to Sharing - nothing should be ticked in any of the boxes.

Now under Store - read the large number of options carefully, particularly the bottom four. Choose what suits you.

Ian

Northroad52
10-19-2016, 07:13 PM
Well, I unchecked the "Show Apple Music Features" box. There is nothing about iCloud Music Library under iTunes preferences. It turns out only a few albums were affected, most of my music is still here. It just gets annoying when you think you have something, then find out it's in the cloud. This is especially bad on the North Slope where I work, as we are often in a remote area for weeks at a time and would like to listen to some music or read a book downloaded to the Kindle app, only to find out it's inaccessable. That's why we have 64 gig iPads and phones to begin with. Rant's over, thanks for the help!

IWT
10-19-2016, 07:52 PM
Northroad52

Are you saying that in Mavericks, when you open iTunes, then iTunes Preferences, then General that you do see "Show Apple Music Features" but DON"T see "iCloud Music Library" immediately under it? Because that's the arrangement on my second/older iMac running Mavericks.

It's set up slightly differently in El Capitan.

Ian

Northroad52
10-21-2016, 12:58 AM
That's correct, no iCloud music library. It turns out that the problem only affected a few albums and I got them downloaded again. Last night I bit the bullet and upgraded to Sierra, which opened a brand new can of worms, but didn't affect my music. Thanks everyone for the help.