PDA

View Full Version : Itunes not playing music on imac



macca75
10-08-2015, 08:46 PM
Hi
Suddenly and for no apparent reason iTunes has stopped playing music on my mac. I click on a song and it appears at the of of the screen but doesn't play. the counter sits at zero and even if i click to later in the song the cursor just stays there. Any ideas? it was fine a week or so ago
be grateful for any advice. Thanks

chas_m
10-08-2015, 10:08 PM
Not really enough details to even begin to figure out what is going on, but a few general troubleshooting notes that might fix the issue (it would be helpful if you could tell us what OS X version you are running, what version of iTunes, specifically what iMac model we're talking about, whether or not you're on Apple Music, and so forth):

1. Try restarting.
2. Try restarting with the SHIFT key held down until you see a login screen with the words "SAFE MODE" in red on it. Log in, let the system fully load, then restart normally.
3. Run a maintenance utility like OnyX (http://www.titanium.free.fr/downloadonyx.php). DO NOT repeat DO NOT download any kind of "cleaner" program like MacKeeper!
4. Disable and remove all so-called "anti-virus" software.
5. If you have the software firewall turned on, turn it off.

macca75
10-09-2015, 04:28 AM
Hi Sorry about the lack of details. Im running iTunes 12.3.044, on Yosemite. Its an iMac 27" late 2013,. Im not on Apple music and I don't have any anti virus software installed. No i wouldnt use anything like mackeeper. The only change that I've made recently is added a dac to my set up but this shows up ok as the sound output source in preferences ok. as i said all was fine a week ago. thanks

chas_m
10-09-2015, 10:39 PM
What happens if you remove the DAC from the equation? What happens if you sign in as a guest user and try to play audio, or a sample of a song from the iTunes Store? Is the sound problem limited to ONLY iTunes, or does it happen anywhere else (QuickTime, for example)?

macca75
10-26-2015, 10:23 PM
Removing the dac makes no difference. Sample from a song in iTunes store same issue. problem only relates to iTunes. Music from sonos also going through the dac works fine. Quicktime is fine. Ive tried reinstalling iTunes but that makes no difference either. Totally puzzled by this one. been using macs since 2008 and never come across this issue before.

chas_m
10-26-2015, 10:34 PM
So just to make sure I have the full picture, all other sources of sound play normally, but iTunes alone won't play. This remains true even if you switch accounts.

Another couple of hare-brained ideas:

1. iTunes has its own volume. How's that look?

2. Is it possible the iTunes is set to AirPlay anywhere?

macca75
10-27-2015, 08:07 AM
Hi again
I tunes volume is ok and yes same thing happens if i use the guest account. What is really odd is if i quit iTunes and then reopen in click on a track it plays. Click on another and it doesn't . have tried this with lots of tracks so nothing specific about the music . So in summary by closing and reopening iTunes i can play the first track i click after doing this but nothing there after.

I also note that if i look at the iTunes folder in finder there is a file called corrupt.itl . Not sure if that should be there but it doesn't sound as if it should but not going to delete it until i know its not there for any purpose. thanks

macca75
10-27-2015, 08:09 AM
sorry i didn't answer your air play question. No not anything to do with this or volume - when its not playing the cursor stays at 0.00 and doesn't move so its not a volume issue its just not reading the track

mrplow
10-27-2015, 08:56 AM
Sounds like your library file is damaged.

Do you use Time Machine? If so, close iTunes. Copy the itl and xml files that are in that folder to a temp folder on your desktop. Use time machine and look in the same folder that corrupt.itl is in from 1week ago or more for when it was iTunes Library.itl rather than corrupt.itl.
Copy these files from time machine to the iTunes folder.
Restart iTunes and try again