PDA

View Full Version : Multiple longterm problems with iMovie; must keep restarting



eileenba
06-16-2015, 08:49 AM
I have iMovie 9.0.9 running on a MacBook Pro Retina (December 2013), 500 GB flash storage. 2.6 GHz Intel Core i7, 16 GB RAM. Running Yosemite. I bought this setup specifically to make movies.

I have to quit iMovie about every 3-5 minutes when editing to make it functional again. Various things happen. The most common is when I am attempting to scroll through to select clips in events, the viewer above freezes on one frame and doesn't advance (even though I am moving the cursor). Often the image that shows in the editing window isnít even from that Event. If I want to trim 1 second off a clip in the movie, I can't watch the action change. I just have to look at the length of the clip.

Sometimes when playing back the movie the image freezes but the sound continues.

Frequently I get black screen when moving through the movie itself. It starts with one clip but soon spreads so that I canít edit. Seems to happen especially when I do a lot of title frames (I make educational movies).

I can never play a movie in full screen mode without restarting iMovie immediately beforehand, and sometimes even then it freezes and crashes.

This acts like an insufficient memory problem to me. The problem is worse when I am low on storage space, but still exists when I have 100 GB available or so.

Often the processor runs really hot/fast when editing.

The computer has done this through every version of iMovie I've ever had (including the newer one; I returned to 9.0.9). I always quit all other applications when using iMovie.

I donít think my black frame problem is the same as others have reported where specific clips are corrupted. It is a progressive problem after I have been working for a while. It happens with every movie I make. My movies are generally 2-4 minutes long. Once in a while up to 8-10 minutes.

I separate my iPhoto library (creating libraries through Aperture) into years since I do have a lot of video clips and the hard drive is so small. A lot of my events are on external drives, but the problem exists even when everything is on the Pro.

Before I spring for a new Pro with a 1 TB drive, does anyone have any suggestions? So sick of this. Thank's for reading this far!