PDA

View Full Version : Having trouble getting Clavinova piano to talk to Garage Band



jaysne
06-12-2015, 05:13 PM
I have a CLP-260 Yamaha Clavinova piano that I want to connect to Garage Band so I can record myself playing, and then use GB to edit the music. The computer is a MacBook Air (10.7.5).

I've tried several different connections, but so far GB has been unable to pick up the direct connection from my piano.

Here is what I've tried:
1) I hooked up a Sanoxy USB/Midi Cable Converter to the piano's MIDI-out jack and connected the USB end to the MBA. The good news is that GB detected the MIDI input: "MIDI Status: 1 MIDI Input(s) detected", but when I started playing the piano on a Software Instrument Track, GB didn't pick it up. (More specifically, I hit record and the track began to record with a highlighted area appearing on the timeline, but I saw no audio levels registering on the meters. When I hit stop, the highlighted area on the timeline disappeared.)

2) Using an RCA plug/USB cable, I connected the RCA plugs to the piano's optional output jacks and connected the USB end to the MBA. Again, GB did not pick up the piano. In fact, this connection was not even detected in the Sound Input Preferences.

3) I downloaded a "USB-MIDI Driver for Mac" driver from Yamaha's website that is supposed to help with connecting Clavinovas to computers. It did not make things work.

I have a hunch that there's probably one simple setting that's not in the proper place. Can anyone help? Thanks.

gsahli
06-12-2015, 05:57 PM
For attempt #1,
Did you check audio input in System Prefs as well as GarageBand Prefs?
Can you try some other capture software - to confirm that the USB-midi device works?

jaysne
06-12-2015, 07:55 PM
I just figured out what was wrong.

I had the "In" plugged into the "in" jack. And it should have been the opposite. (Likewise for the "Out" connections.)

D'oh! But I'm happy.