PDA

View Full Version : Read-only iPhone interface



mrplow
01-14-2013, 05:45 AM
Is there any way to select a usable iPhone interface for the forum?

If I get a notification of a thread update by email, on my iPhone, the link takes me to a read only interface.

I can select 'full desktop site' but that just takes me to the default landing page for the forum and not to the full site version of the page I was on. So I then have to go hunting down the thread I was on.

Very frustrating.

I'd love a usable iPhone interface as a preference but will settle for just defaulting to the full desktop site if necessary. I just want to switch off the far too basic read-only site.

Any chance?

chscag
01-14-2013, 02:54 PM
I'm going to pass along your concern to our iNet folks. Are you seeing the same thing on your iPad? The reason I ask is I can get to the full thread on my iPad, however, I do not at present own an iPhone.

I.M.O.G.
01-14-2013, 03:07 PM
I just had to do that to reply on my Nexus 4. Select full site link at the footer, use the back function of the browser, then I got the desktop version of this thread. Non-optimal.

I would think changing this behavior is a simple URL change on the full site link in the footer. I will ask and get back to you.

mrplow
01-14-2013, 05:44 PM
iPad is fine, full desktop site works brilliantly. That's what it defaults to.

osxx
01-14-2013, 05:57 PM
iPad is fine, full desktop site works brilliantly. That's what it defaults to.

Same here.

bobtomay
01-14-2013, 08:05 PM
I gave up on using the Safari web browser.

Using Atomic Browser - in the settings for "Identify Browser As", I have it set to Firefox 15.
Just about always get full web sites with that setting instead of some iPhone browser which pretty much sucks on most web sites. (Well, they could be better now. Probably been 2 years I've been using this setting.)

XJ-linux
01-14-2013, 09:14 PM
Same issue here. I always get the mobile read-only version. I select full version (which doesen't seem to persist between sessions), and then have to track down the thread to post in it. It's partly why I don't post as much as I use to (other than a quick comment) - physically at work (using iPhone) more and on my MBA less often. Too much a hassle to mess with posting most of the time on the iPhone.

mrplow
01-15-2013, 02:04 AM
Atomic is a great browser but, unfortunately, the link in an email will only open Safari so it's still a copy, open, paste job.

I.M.O.G.
01-15-2013, 11:31 AM
That's a real pain. I've got a feature ticket in to fix the way it works. It shouldn't have ever worked the way it does, but thats what we have now, so I'm hopeful we can make it work better soon.

mrplow
01-15-2013, 02:17 PM
That's great news

cwa107
02-03-2013, 12:22 PM
That's a real pain. I've got a feature ticket in to fix the way it works. It shouldn't have ever worked the way it does, but thats what we have now, so I'm hopeful we can make it work better soon.

Any update on this, IMOG?

If we can't get this working in short order, I would prefer to just turn it off as the default skin until the devs can figure it out.

Thanks.

I.M.O.G.
02-04-2013, 02:12 PM
The ticket is in the work queue, however our team has gotten behind on maintenance tasks due to some top priority enhancements to various sites. I just asked, and I'm told that when the weekly dev cycle starts this Wednesday, we'll have more of our resources back on maintenance tasks, which should help tickets like this one get resolved.

The ticket was submitted on 1/14, so it will be 3 weeks on Thursday. That sort of turnaround time on an issue like this is a problem for us, and I've made that clear. My boss just made it a top priority for the coming week for our group, so that increases chances that it will get attention sooner.

I don't know how to turn it off as the default mobile skin, otherwise I would do so until we had a solution in place. Right now, my understanding is that it might get done in the next week. But at worst, it could take 2 to 3 more weeks to get dev time assigned. Getting work like this done more responsively has been a priority for me every day for the past year, and I keep voicing this to management. I think it especially important with items like this which should have been done correctly to start, but somehow were not... When things require revisiting like this, it seems like they take the longest.

cwa107
02-04-2013, 02:27 PM
I understand Matt. Thanks for pushing it along.

Though I can manage with Chrome on the iPhone, it's a bit of a pain when reacting to emails and has been a source of frustration for some time now.

I.M.O.G.
02-04-2013, 04:44 PM
Ya, its a stupid problem, and should be easy to fix. Frustrating.

mrplow
04-04-2013, 05:27 AM
Do you have an update this at all?

I.M.O.G.
04-04-2013, 12:20 PM
It was resolved weeks ago. If you are still having trouble, please describe it for me.

mrplow
04-04-2013, 12:53 PM
Perhaps I misunderstood the solution. I'm still dropping into the read-only view but full desktop site link does now stay on the same thread. Was that the solution?

I.M.O.G.
04-04-2013, 03:52 PM
Correct, the specific item fixed was reading a thread, and switching from mobile to desktop view directly, without losing the thread.

mrplow
04-04-2013, 06:09 PM
Ok thanks.

I.M.O.G.
04-04-2013, 11:15 PM
Is there something else you'd like fixed too? We could look at it.

I'm also hoping to bring tapatalk over, as they've changed their pricing scheme, and we're currently running tapatalk for android and iOS on webhostingtalk... That way we can have a mobile experience that you can actually post in!

cwa107
04-04-2013, 11:25 PM
I'm also hoping to bring tapatalk over, as they've changed their pricing scheme, and we're currently running tapatalk for android and iOS on webhostingtalk... That way we can have a mobile experience that you can actually post in!

Never thought I'd say this, but bring it on!

mrplow
04-05-2013, 02:02 AM
Yes, I'd love a mobile interface that allows posting.

If tapatalk is feasible that would be great

mrplow
11-05-2013, 06:12 AM
Sorry to dig up this old chestnut but is there any plan to allow posting from an iPhone?

Recently there seems to be a backward step in that even selecting the desktop view just refreshes and re-displays the mobile read-only view.

Has something changed of is this a new iOS7-ism?

cwa107
11-05-2013, 08:30 AM
Sorry to dig up this old chestnut but is there any plan to allow posting from an iPhone?

Recently there seems to be a backward step in that even selecting the desktop view just refreshes and re-displays the mobile read-only view.

Has something changed of is this a new iOS7-ism?

Yes, I've noticed the same. It's definitely annoying, to say the least. I will try to get the problem corrected.

In the meantime, I recommend the Atomic Web Browser, available in the app store - it allows you to spoof your browser's identity, essentially tricking websites like our own, to display the full page.

mrplow
11-05-2013, 08:33 AM
Thanks chap.

I do tend to use Atomic. It's handy for some tricky websites that don't play nice with certain browsers. Just can't automatically follow email links from mac-forums.

dbm
10-08-2014, 08:26 PM
Resurrecting this thread, I've just learned that iOS 8 has the solution to this challenge (I am posting this from my iPhone with Safari).

After navigating to the forum url, once the phone interface shows just tap on the address bar. The favourites tab will open; pull this tab down to show two further options. One is "Request Desktop Site" - selecting this will indeed bring up the full version of the site!

chscag
10-08-2014, 10:49 PM
Just in case you don't already know, but there is now a free TapaTalk app for our forums which you can download from the iTunes app store. It's called "Mac Forums" and works very well. Give it a try.

dbm
10-09-2014, 01:29 PM
I have tapatalk and use it for other forums. When I search for 'Mac' this site doesn't appear - any suggestions?

cwa107
10-09-2014, 01:34 PM
It doesn't use the Tapatalk app. Rather it has its own dedicated app:

https://itunes.apple.com/us/app/mac-forums/id843839605?mt=8

chscag
10-09-2014, 02:14 PM
The description in the iTunes App Store states that it updates the base Tapatalk software to the latest version (3.8.11). And it was my understanding that it in fact uses Tapatalk. Maybe we need to clarify if this app is Tapatalk modified to work with our forums?

I have used it and I have old eyes - so if it works for me, it should work for most folks.

chscag
10-09-2014, 02:16 PM
I have tapatalk and use it for other forums. When I search for 'Mac' this site doesn't appear - any suggestions?

As Chris stated, you need to search the iTunes app store for the "Mac Forums" app not Tapatalk. The app (according to the description in the iTunes store uses the latest version of Tapatalk.

cwa107
10-09-2014, 02:31 PM
Tapatalk is two pieces - first, there's a server-side piece that actually provides the data in a way that is palatable to the second piece, the client. There is a general Tapatalk client that one can download and choose from an index of hundreds of Tapatalk sites. That said, we do not work with that service - we have our own custom app.

In this way, Tapatalk is running behind the scenes and we get a cleaner representation of our brand - or at least that's how iNet chose to do it.

chscag
10-09-2014, 02:37 PM
Thanks for the explanation Chris.

rmafx
03-26-2015, 07:41 PM
thank youv verey mach