PDA

View Full Version : iWeb site emits Virus warning/error messages



seekzpeace
04-16-2011, 01:30 PM
My website has recently emitted warnings and error messages. Sometimes it wants me to "accept" an applet? I personally haven't seen the virus warnings, but it's been reported to me from other users. My host has gone in 2x and 'fixed' things, but it keeps happening.

Is this from my end? From using iWeb? ('09). Would there be problems from having a zazzle.com panel on my site? Blog talk radio?

What to do!? Anything from my end, or is this just up to my host?

Thanks in advance!!!

chscag
04-16-2011, 02:37 PM
I don't see how this could be blamed on iWeb. Unless you're adding questionable content to your site, it should be up to your host to keep it clean. My guess would be that your site has been invaded by something you have no control over. Again, it's up to your host. Complain to them about it. If it continues, consider moving your site.

vansmith
04-16-2011, 02:49 PM
Sometimes it wants me to "accept" an applet? [...] Would there be problems from having a zazzle.com panel on my site? Blog talk radio?It appears that the zazzle panel is a Flash app so that won't be it but what is this "blog talk radio" thing your referring to here? If it's a Java applet, it's very possible that it will require the permission of the user as some Java applets require this to run. Can you get someone to send you a screenshot of this?

seekzpeace
04-16-2011, 02:50 PM
Much appreciation for both replies!

Here's the site; http://www.stylestickers.net ~ the blog talk radio link is on this page;
about us (http://www.stylestickers.net/StyleStickers/About_Us.html)

seekzpeace
04-16-2011, 03:26 PM
Not sure if my first reply is on 'hold' for approval or what, but I will repeat it here;

First off, thanks for both replies!

Here is my site: http://www.stylestickers.net
the Blog talk radio link is on this page:
about us (http://www.stylestickers.net/StyleStickers/About_Us.html)

Can you tell anything by just looking at that link?

Thank you!

vansmith
04-16-2011, 04:02 PM
There doesn't seem to be anything out of the ordinary. My guess is that it is perhaps something on the server side since you mention that your webhost has fixed it (however temporary it is). Can you get a screenshot of the popup or a description of the issue from your webhost?

seekzpeace
04-16-2011, 04:06 PM
I'll get the description from him. Screenshot, I'll do that if the issue comes up again on my end. He changed the ftp password today, and that "fixed" it at this point.

Thanks for your help! I'll be back...

seekzpeace
04-16-2011, 05:15 PM
Here's my host's latest reply. Hope it helps;

"I wish I could go back and look at the code I removed. The most recent time it was loading some kind of javascript from some other website. Previously there were several such entries. Somehow that javascript code is getting inserted in the header in the index.html page."

I asked him to keep an eye out and we will capture it again if it reoccurs.

Thx!

vansmith
04-16-2011, 06:29 PM
It sounds as if someone has access to your web hosting account and is changing the files. In their description, they are essentially saying that code is being added to your web page (the index page is the page that's loaded when someone goes to your website). This may make sense given that the problem seems to go away when you change your FTP password. This is something best solved with the assistance of your webhost (assuming that this is indeed the problem).

seekzpeace
04-16-2011, 07:21 PM
The only one who has access is my web host. So you are saying you think someone ELSE has access and is maliciously adding something?

dtravis7
04-16-2011, 07:28 PM
The only one who has access is my web host. So you are saying you think someone ELSE has access and is maliciously adding something?


When I just read all your posts, that was the first thing that came into my mind also! How is that code getting in to your code?

seekzpeace
04-16-2011, 07:32 PM
Hhhhhmm. Weird. Who knows!!! Well, let's hope his changing the password has fixed it. If not, like chscag suggested, I will move hosts!

Thanks all! Will let you know if anything else comes up with this issue!

vansmith
04-17-2011, 12:52 PM
Discuss this with your webhost and ask if they have access logs. If they do, they can tell you who has been logging in (probably by IP). They'd be able to tell you if there are any discrepancies or any unusual activity from an IP different from yours.

seekzpeace
04-17-2011, 05:27 PM
Ok. Will do. Begun wondering if using Sitemeter is causing any problems. Wondering if I should change counters to a different service.

seekzpeace
04-17-2011, 07:20 PM
Hey, if anyone is online...favor....

Please check my splash page ~ http://www.stylestickers.net and tell me 1) is the sitemeter logo still there...and does it take you to my (private!) stats!? and 2) is my zazzle panel now partially hidden at the bottom of the page?

I use iWeb and sometimes it makes THE most quirkiest, random placement of things. Obviously, I didn't mean to do ANY of the above, but on Safari and Chrome, those quirks are showing. Not so on Firefox.

MADDENING! Thanks!

dtravis7
04-17-2011, 07:23 PM
For sure I am seeing SiteMeter at the very bottom of the page. I clicked on it and got the stats.

seekzpeace
04-17-2011, 07:24 PM
Holy crap.

At the BOTTOM of the page? Where is the zazzle panel? What browser are u using?

I'd laugh if I weren't so frustrated!? (Thx!)

dtravis7
04-17-2011, 07:26 PM
Latest Safari. I see a url with Zazzle in it.

seekzpeace
04-17-2011, 07:30 PM
I should have a zazzle panel up in addition to the url's....it shows products rotating.

I now think Sitemeter is evil....(but maybe I should be mad at iWeb....)

Tried to add Google analytics and eliminate Sitemeter, but obviously Sitemeter is not going away......

seekzpeace
04-17-2011, 09:17 PM
Ah ha....emptied my cache...and now all 3 browsers are showing my site as I updated it.
Phew.