PDA

View Full Version : iWeb with internet explorer....anybody...?



jastafied
04-11-2011, 10:56 AM
I just stayed up all night working on a site for a relative (that I'm getting paid for). I got it looking pretty decent but once again Internet Explorer decided to ruin my life. The majority of the links will not work and there's this dim grey box surrounding the center of the site (which I never made to begin with). I don't have time to learn new extensive CSS/xhtml and whatnot, which is why myself and most other people use iWeb in the first place. I have enough knowledge of it to get me by, but I'm no means fluent at it.
As long as I could get the links to work I guess I'd be alright with seeing that ugly grey box...but would prefer to get rid of that as well.

If you know any solutions please send them my way, I'm tired and quite frustrated! My site is currently at www.pat-swope.info

chscag
04-11-2011, 11:24 AM
Moved to correct forum. Your chance of receiving helpful replies are greater here then in the Applications forum.

jastafied
04-11-2011, 01:52 PM
oops, first post on here...haha

Aptmunich
04-11-2011, 02:59 PM
Which version of Internet Explorer? If it's version 6, I'd be tempted to ignore it (unless that's what the client is using of course ;))

louishen
04-11-2011, 03:21 PM
If you know hoe to put code in the head of each page then I recommend the google IE code, which only targets IE and cures most of the standards quirks in Internet explorer


<!--[if lt IE 8]>
<script src="http://ie7-js.googlecode.com/svn/version/2.1(beta4)/IE8.js"></script>
<![endif]-->


And grey boxes are often caused by IE not being able to render PNGs properly, so this code is needed in the head as well


<script src="IE8.js">IE7_PNG_SUFFIX=".png";</script>

That will cure many of the IE bugs and save you a lot of pain

MacHighway_Ryan
04-20-2011, 03:36 PM
If you're using iWeb to design your site my best suggestion would be to try different templates and see which one displays you information correctly (or at least better) with IE. From my experience, IE is often problematic for iWeb created sites.

You may also want to look into other design apps, like RapidWeaver, Sandvox, or Freeway. All of which typically have less issues displaying correctly in most every browser, including IE.

Hope that helps. :)

smultron
04-26-2011, 01:07 AM
Hi,

This should help you. It is a video tutorial explaining how to get an iWeb site to work better with Internet Explorer.
iWeb and Internet Explorer video (http://www.ragesw.com/blog/2011/04/25/iweb-internet-explorer-optimize/)