PDA

View Full Version : iTunes Music locations problem



ComputerStation
05-07-2010, 12:20 PM
Hey, I am new to the Mac Forums

So I have just purchased a new MacBook Pro 13" and I love it so far. But I am having a problem with iTunes.

When I made my own iTunes library I made it on a Windows OS, which isn't a problem but the majority of the songs added were from various folders across my Windows HD. These files were not copied to the iTunes music folder.

So when I got my Mac I used a program on my PC called Synkron to sync all of my files to my Mac including my iTunes folder like it should to make it so all of my computers are identical.

Because it has synchronized all of my iTunes folder I can see my library on my Mac exactly the same as the Windows library - Normal

But when I go to my Mac and play a song which was imported from another folder on my hard disk to the iTunes library my Mac can't locate the file - and there's over 800 of these so I can't quite locate each one individually.

It only plays my CD's that I have imported because I imported them with iTunes therefore making them being copied over to my iTunes music folder. This is not the case with the other files because they aren't in the iTunes folder.

I think this is because Windows has a different hard disk directory than the Mac.

So I have tried copying these files to my iTunes folder but that doesn't work (It still says I need to locate them)

Yes - The files that won't play in iTunes ARE copied over to my Mac's HD so I can locate the files and they work fine but that will take forever

So I need a permanent fix so that I can still sync my computers with Synkron without this problem occuring again.

I hope at least one of you understands this problem and has a solution.

blackmac11
05-07-2010, 04:28 PM
I think you just need to change the directory that iTunes is looking in. Go to iTunes/preferences/advanced and click inside the box that says 'iTunes media folder location'. Then replace the current directory to the folder that has all your music in it.

Report back if this isn't the problem your having

ComputerStation
05-07-2010, 04:55 PM
I think you just need to change the directory that iTunes is looking in. Go to iTunes/preferences/advanced and click inside the box that says 'iTunes media folder location'. Then replace the current directory to the folder that has all your music in it.

Report back if this isn't the problem your having

That's the thing, I have music in my iTunes music folder as well as the other folders in my Mac's music folder if you get what I mean. It still doesn't find them if I change the location in the iTunes preferences.

RavingMac
05-07-2010, 05:01 PM
Just moving the music to the iTunes folder isn't enough to make iTunes recognize it. If you double click on a song in the folder it should pop up in iTunes and begin to play, or alternately you can drag it into iTunes but I think this may end up with a duplicate in your iTunes Library.
I do know that double clicking the file works, you don't have to let it play and can move immediately to the next file. Kind of a drag if you have a lot of files, but it does the job.

ComputerStation
05-07-2010, 05:05 PM
Just moving the music to the iTunes folder isn't enough to make iTunes recognize it. If you double click on a song in the folder it should pop up in iTunes and begin to play, or alternately you can drag it into iTunes but I think this may end up with a duplicate in your iTunes Library.
I do know that double clicking the file works, you don't have to let it play and can move immediately to the next file. Kind of a drag if you have a lot of files, but it does the job.

Thanks, I suppose this is the only way to do this without re-importing my library again. Do you think the problem will occur again when I sync my files between my Mac and my PC?

ComputerStation
05-07-2010, 05:15 PM
I just tried clicking on them individually and it works but it makes duplicates which is going to mess all of my syncing up. Any other ideas?

RavingMac
05-07-2010, 06:55 PM
Sorry,
Been thinking about it I can't think of anyway that isn't likely to give you the duplicate listing problem to deal with. Maybe someone else on the Forum has a better idea.

blackmac11
05-08-2010, 02:31 AM
Very easy to delete duplicates after you are done importing:

In iTunes, click File/Show duplicates and iTunes will check all the repeated songs. Simply hit delete from iTunes and you are done :)