PDA

View Full Version : Installing windows 7 from USB



Bassi
02-08-2010, 04:51 PM
I have a Intel iMac, rev. 8,1.. Bought November 2008.

I am trying to install Windows 7 32 bit on it..

I have already wiped it clean and used a Windows 7 64 bit DVD to install.
But I've chosen to go back to 32 bit... But I've run out of DVD's.

So now I am trying to install from USB and I can't get the **** EFI to boot from my usb.. I've used this guide to make my USB bootable:
Install Windows 7 From USB Drive/Pen Drive (http://www.intowindows.com/how-to-install-windows-7vista-from-usb-drive-detailed-100-working-guide/)

That've worked pretty good for me in the past.. But maybe's the bootcode I installed to my USB pen only works with Microsoft BIOS and not with Apple EFI?

And as I only have WIn 7 64 bit installed I don't get boot options in the EFI menu when I start the machine. Not even when I plug my newly bootable windows 7 USB stick in...

I have a hunch I just need to hold down some weird key or something to get it to boot? Or isn't it that simple?

cwa107
02-08-2010, 05:07 PM
Are you holding down the Option key when you first turn the Mac on?

Bassi
02-09-2010, 05:41 AM
I just tried that.
The only option I get is my windows partition...

Any other ideas as to how I can get EFI to see me windows 7 USB stick and boot from it?

cwa107
02-09-2010, 10:43 AM
Admittedly, I have not tried this on a Mac before, but it was very simple on the Acer Aspire One I did for a customer.

Not sure which tutorial you used, but have a look at this one...

How To: Install Windows 7 from a USB Key! | Maximum PC (http://www.maximumpc.com/article/howtos/how_to_install_windows_7_beta_a_usb_key)

EFI is usually pretty indiscriminate about bootable devices, as long as there is a valid boot sector on the disk.

Bassi
02-10-2010, 09:24 AM
I don't know how you "cannot" be sure about wich tutorial I used since I linked to it..

But anyway, I grew tired of this problem, and simply burned it to a DVD. There. Problem fixed. Stupid EFI..

Oh, and btw I tried my "bootable" windows 7 USB on my CompaQ laptop with BIOS and it worked.. So apple's "bios" here is the problem

cwa107
02-10-2010, 09:29 AM
I don't know how you "cannot" be sure about wich tutorial I used since I linked to it..

Sorry about that, I missed it. But I can't tell you how much I appreciate your congeniality toward those that are trying to help you.