PDA

View Full Version : Writing to Time Machine Backups drive from Linux



sworddude182
12-12-2009, 05:18 PM
Hello,

I have a 700 gb external hard drive that I use for my Time Machine Backups on my Macbook Pro, but the Macbook only has a 320 gb hard drive and I have a ton of extra space. Time Machine wouldn't allow me to have more than one partition on the drive. The drive is formatted in HFS+ (or however Time Machine sets it up).

I'm about to wipe the drive on a different laptop running Windows, and I have about 100 gb of files I want to back up. Windows will not mount the HFS+ external drive, so I decided to use a live USB with Ubuntu 9 to boot Linux and copy the files from the laptop to the external drive.

The Time Machine drive mounts properly when I plug it into the second laptop running linux from the usb. It shows up on the desktop and I can see the files already on it. However, when I try to copy anything to the drive, an error pops up showing that the drive is read only.

I opened terminal and typed mount, and it read the following:
/dev/sdc2 on /media/Time Machine Backups type hfsplus (rw,nosuid,nodev,uhelper=devkit)

I was surprised that the drive was labelled rw, so I reconnected the drive to my Macbook, and checked the permissions. It was set to read and write for everyone, but just in case I made a new permission for user "ubuntu", which is the user the live USB loads into, and labelled it read and write. That didn't do anything..

Any ideas as to how I can write things to my external Time Machine drive from Linux?

Thanks!

Raz0rEdge
12-12-2009, 05:29 PM
Do the following


cd /media/Time\ Machine\ Backups
ls -l

This will most likely show that the files on here are owned by Root, so unless you do the copy preceded with "sudo" it won't be able to copy the files there. You can change that adding the options "uid=1000,gid=1000" to the Mount command to give your user account RW permissions as well.

Regards

sworddude182
12-12-2009, 06:01 PM
Do the following


cd /media/Time\ Machine\ Backups
ls -l



I tried the ls -l and the results look something like this:



drwxr-xr-x 1 502 dialout 19 2009-12-11 16:39 Movies
... (and multiple similar entries)

Although one entry had "root" where the 502 was.

in /media I did ls -l and it looked like this:


drwxrwxrwx 1 502 dialout 22 2009-12-12 09:41 Time Machine Backups



Ideas?

sworddude182
12-12-2009, 06:31 PM
oh and I tried copying as root and an error message came up showing that the drive was read only...

hmm

chscag
12-12-2009, 09:12 PM
Instead of messing around with Linux why not just use Disk Utility and partition the drive? Create one partition as HFS extended journaled for Time Machine backups and the second partition as FAT-32 for your Windows files.

Note: Whenever you let Time Machine setup an external drive it wants to use the whole drive. The way around that is to use Disk Utility instead.

Regards.