Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Jun 29, 2011
    Posts
    43
    Macbook is not outputting 5.1 surround through hdmi...
    I have a 2011 macbook pro with a thunderbolt/hdmi adapter connected to a receiver, so I can watch movies on my tv. Video files with 5.1 dolby have always played fine through this exact setup, however, recently, only 2 channel pcm audio goes through and is recognized on the receiver.

    I know that the adapter is good, and it isn't the receiver because I have tried other devices on the same ports. So it must be something on the macbook end.
    8 channel is selected under hdmi in midi options, and hdmi is always selected as output in the movie player I use. There is no reason it should still only be 2 channel on my receiver.

    I have tried 3 different hdmi cables and 2 different thunderbolt to hdmi adapters. All the same. Also, all the hdmi ports on my receiver have dolby with other devices (such as my ps3, cable, etc) SO I can rule out the receiver and the cables...it has to be my macbook.

    I am dying to find an answer to this...asked the question multiple times in the apple community with not even one response...please help if you have any ideas!
    Thank you


    PS. I am on 10.7.4 using an Onkyo HT-R590 receiver. I currently have 2 different adapters that I know both work.

  2. #2
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Feb 25, 2009
    Posts
    2,109
    Specs:
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    It is possible that whatever you're using to play movies is selecting the wrong audio stream. you might want to check the applications menus on a movie playing wrong to see which audio stream is selected and if you can select an alternate stream.
    My Macs: Late 2013 rMBP w/ 750m; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Debian as a server; Apple TV (1080p version)

  3. #3
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Jun 29, 2011
    Posts
    43
    Quote Originally Posted by Nethfel View Post
    It is possible that whatever you're using to play movies is selecting the wrong audio stream. you might want to check the applications menus on a movie playing wrong to see which audio stream is selected and if you can select an alternate stream.
    Ya, hdmi is always selected.
    But that doesn't matter. It should automatically be sending a 5.1 signal... regardless if I'm playing a movie or not.

    It has always in the past...as soon as I plug the hdmi in it shows 5.1...just so confused and frustrated

    Would a clean install of Lion help?
    It has to be software related I'm guessing....thanks

  4. #4
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Feb 25, 2009
    Posts
    2,109
    Specs:
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    HDMI connection technology, not the audio stream within the file. The receiver will decode the audio that is being sent over HDMI, if the software is sending left/right stereo, that's what it will show. Most movie files that are M4V's (iTunes compatible) have at least 2 audio streams, a stereo stream and (optionally) a surround sound stream. Your software could be pumping out the wrong stream.
    My Macs: Late 2013 rMBP w/ 750m; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Debian as a server; Apple TV (1080p version)

  5. #5
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Jun 29, 2011
    Posts
    43
    Quote Originally Posted by Nethfel View Post
    HDMI connection technology, not the audio stream within the file. The receiver will decode the audio that is being sent over HDMI, if the software is sending left/right stereo, that's what it will show. Most movie files that are M4V's (iTunes compatible) have at least 2 audio streams, a stereo stream and (optionally) a surround sound stream. Your software could be pumping out the wrong stream.
    Yes. I've narrowed this down to be the problem.
    However, I'm playing MKV files that clearly have 5.1 dolby.
    Any ideas how to make the software send a different stream?

    (I use VLC to play audio. It is set as hdmi output) But either way, the receiver never recognizes anything other than pcm 2 channel

  6. #6
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Feb 25, 2009
    Posts
    2,109
    Specs:
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    MKV's have multiple streams too - have you checked what's actually in the file? Perhaps it's sending the stereo stream instead of the 5.1 stream. I know whenever I encode an MKV I have a stereo track and optionally a 5.1 (or 7.1) track. What software are you using for playback? If you're using VLC the audio track selection would be in the Audio menu. If you're using Movist, MPlayerX, Plex the settings are there but just in possibly a different menu (I'm at work atm and don't have all of those on this system)

    Another option in VLC is to go into the preferences, under the audio preferences and try to force detection of dolby surround
    My Macs: Late 2013 rMBP w/ 750m; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Debian as a server; Apple TV (1080p version)

  7. #7
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Jun 29, 2011
    Posts
    43
    Quote Originally Posted by Nethfel View Post
    MKV's have multiple streams too - have you checked what's actually in the file? Perhaps it's sending the stereo stream instead of the 5.1 stream. I know whenever I encode an MKV I have a stereo track and optionally a 5.1 (or 7.1) track. What software are you using for playback? If you're using VLC the audio track selection would be in the Audio menu. If you're using Movist, MPlayerX, Plex the settings are there but just in possibly a different menu (I'm at work atm and don't have all of those on this system)
    Thanks
    However, the same MKV files that used to play fine in dolby on this exact setup (same macbook, same adapter, same receiver) now don't.
    Also, the macbook doesn't output 5.1 for regular audio such as music from itunes either. So either way, it can't be the MKV or the player. Nothing in any format in any program goes through in anything other than 2 channel :/

  8. #8
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Feb 25, 2009
    Posts
    2,109
    Specs:
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    I tested mine over the weekend to see if I could replicate what you were seeing.

    First I noticed (as I expected) when outputting audio from songs (MP3's) the system shifted to stereo. This is what I'd expect since iTunes doesn't up convert a song from stereo to 5.1 even outputting over hdmi.

    iTunes movies and videos that I have in iTunes that have a 5.1 track come through as 5.1 on my receiver.

    VLC was a different story for me which I don't know why. Although my MKV's are all AC3 5.1 which may be part of my problem - I haven't had time to reencode a video to another 6 channel audio codec yet to see if it's just the AC3 or something else (when selecting the AC3 track it was outputting stereo) and sometimes I did notice after VLC gave me grief about the AC3 track I'd either have to power cycle my receiver or disconnect/reconnect my Mac to get the audio channels to work right back in iTunes (but this wasn't a consistent thing)
    My Macs: Late 2013 rMBP w/ 750m; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Debian as a server; Apple TV (1080p version)

  9. #9
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Jun 29, 2011
    Posts
    43
    Quote Originally Posted by Nethfel View Post
    I tested mine over the weekend to see if I could replicate what you were seeing.

    First I noticed (as I expected) when outputting audio from songs (MP3's) the system shifted to stereo. This is what I'd expect since iTunes doesn't up convert a song from stereo to 5.1 even outputting over hdmi.

    iTunes movies and videos that I have in iTunes that have a 5.1 track come through as 5.1 on my receiver.

    VLC was a different story for me which I don't know why. Although my MKV's are all AC3 5.1 which may be part of my problem - I haven't had time to reencode a video to another 6 channel audio codec yet to see if it's just the AC3 or something else (when selecting the AC3 track it was outputting stereo) and sometimes I did notice after VLC gave me grief about the AC3 track I'd either have to power cycle my receiver or disconnect/reconnect my Mac to get the audio channels to work right back in iTunes (but this wasn't a consistent thing)

    Thanks for doing that!
    When you plug in the macbook (when you don't have anything with audio playing in any programs) does your receiver say dolby or 5.1? When I have nothing playing and the macbook is connected my receiver just says pcm (2 channel) and never changes regardless of what I have playing.

    What are you audio settings at?

    I really appreciate this! No one on any forum has really helped me at all with this and I am starting to get sooo frustrated!

  10. #10
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Feb 25, 2009
    Posts
    2,109
    Specs:
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    I'll have to re-hook it up again - unfortunately, my wife is watching TV so if I interrupt her, I might not be able to help again.... ever

    I do remember when I first connected it to my receiver (an Onkyo) it showed 5.1, I'm pretty sure it showed Dolby Digital on it as well. After I played a song it no longer showed that and only showed stereo sound. Sometimes it would then cycle the receiver back to 5.1 and sometimes it would stay on stereo until I actually played a 5.1 movie in iTunes (this could have been an issue with my receiver, I'm not sure) Once I get a chance to try more again later I'll let you know what I find.

    Just out of curiosity, I know you have other HDMI devices (like the PS3) - have you tried connecting the PS3 to the HDMI port that you connect your Mac to and see what it states - if it sets it to 5.1 / DD?

    One other question - have you tried rebooting your Mac? (just wondering if it's possible the driver is "stuck" in stereo output) And do you have anything plugged into the headset port or no?
    My Macs: Late 2013 rMBP w/ 750m; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Debian as a server; Apple TV (1080p version)

  11. #11
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Jun 29, 2011
    Posts
    43
    Quote Originally Posted by Nethfel View Post
    I'll have to re-hook it up again - unfortunately, my wife is watching TV so if I interrupt her, I might not be able to help again.... ever

    I do remember when I first connected it to my receiver (an Onkyo) it showed 5.1, I'm pretty sure it showed Dolby Digital on it as well. After I played a song it no longer showed that and only showed stereo sound. Sometimes it would then cycle the receiver back to 5.1 and sometimes it would stay on stereo until I actually played a 5.1 movie in iTunes (this could have been an issue with my receiver, I'm not sure) Once I get a chance to try more again later I'll let you know what I find.

    Just out of curiosity, I know you have other HDMI devices (like the PS3) - have you tried connecting the PS3 to the HDMI port that you connect your Mac to and see what it states - if it sets it to 5.1 / DD?

    One other question - have you tried rebooting your Mac? (just wondering if it's possible the driver is "stuck" in stereo output) And do you have anything plugged into the headset port or no?
    Haha..ya, don't interrupt her
    I have plugged both my ps3 and my cable box into the same port as I'm using for macbook and they both got surround sound. ( I have also tried plugging in the macbook into all 5 of the hdmi ports on the receiver...same thing on all of them).

    When I connect a simple aux cable from my headphone jack to the receiver (playing in itunes) the music comes through as dolby 5.1

    Is there a way to play the audio through aux while playing the video through the hdmi? I don't know if there would be any way to do that...but it would solve my problem for now.

    I have tried rebooting the mac, as well as re-installing Lion, resetting the pram and smc, doing every possible combination of channels/hz under midi settings and just about everything else...

    I actually do always have a pair of bose speakers plugged into the headphone jack. However, I just unplugged them and it didn't make a difference.

    It just makes no sense whatsoever...

    Thanks again!

    PS. If I test the speakers under midi settings, no matter which of my 7 speakers I test it all comes out of the front 2...not sure if that's helpful or not

  12. #12
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Dec 13, 2012
    Posts
    3
    did you ever get it to work
    I'm having the same problem with my mbp, I checked the serial number and it is capable of outputting 8 channels. The difference is that I am using the mini dvi-hdmi. I have an Onkyo also (txsr313).

    The receiver is also stating that I'm also getting 2 channel pcm.

    Just wondering if you ever figured it out?

  13. #13
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Jun 29, 2011
    Posts
    43
    Quote Originally Posted by spready1 View Post
    I'm having the same problem with my mbp, I checked the serial number and it is capable of outputting 8 channels. The difference is that I am using the mini dvi-hdmi. I have an Onkyo also (txsr313).

    The receiver is also stating that I'm also getting 2 channel pcm.

    Just wondering if you ever figured it out?

    Nope. Never figured it out.
    Did everything humanly possible.
    The only solution is that now I'm running audio through an optical cable and only video through the hdmi.
    It's a bunch of crap...and Onkyo has horrible customer service.

  14. #14
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Dec 13, 2012
    Posts
    3
    Oh well.... that sux. I'm really trying to reduce wire clutter, so I'll probably play around some more, then I'll probably just deal with the pcm. No plans to call Onkyo.

    thanks for the reply.

    If I get it.. I'll post it.

  15. #15
    Macbook is not outputting 5.1 surround through hdmi...

    Member Since
    Jun 29, 2011
    Posts
    43
    Quote Originally Posted by spready1 View Post
    Oh well.... that sux. I'm really trying to reduce wire clutter, so I'll probably play around some more, then I'll probably just deal with the pcm. No plans to call Onkyo.

    thanks for the reply.

    If I get it.. I'll post it.
    Ya, definitely let me know.
    Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MAcBook Pro outputting power at charging port
    By KyleMath in forum Apple Notebooks
    Replies: 6
    Last Post: 02-05-2015, 03:09 PM
  2. Problems with hdmi adapter and surround sound
    By Teknofobe in forum Music, Audio, and Podcasting
    Replies: 3
    Last Post: 09-09-2012, 07:01 AM
  3. Macbook only outputting Black and White to projector - Help!
    By Collymonster in forum Apple Notebooks
    Replies: 1
    Last Post: 01-11-2012, 02:56 PM
  4. Replies: 2
    Last Post: 12-23-2010, 06:38 PM
  5. Replies: 6
    Last Post: 05-18-2010, 06:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •