Results 1 to 6 of 6
  1. #1
    Brand new MBP out the box, but...no airport connection???
    jhaime's Avatar
    Member Since
    Feb 01, 2009
    Posts
    13
    Brand new MBP out the box, but...no airport connection???
    It refuses to connect to my router! **** frustrating, any help is most appreciated.

    I've purchased the latest 15", quad core, 500GB blah blah...

    Took it out the box, pressed on, took me through all the mandatory language settings and keyboard settings, asked to connect to a network, popped in the relative password for our home network. Ok, sorted I assumed.

    Not to be...

    Initially it was coming up with an exclamation mark across airport and the message 'no internet connection' when you click to see what the deal is...

    So I clicked no internet connection, it took me through the alternatives of DHCP and the other.. used the other to pop in the account name and WAP code to establish the network. Hasn't worked, although has removed the exclamation mark.

    So, still no connection, attempted to turn my airport off on this system (imac), rebooted the router, nothing, nada... MBP still won't connect. So I look up this issue with airport... I tried deleting my home network (that it is actually 'connecting' to with a tick) in keychains, same in the advanced network preferences, re-load the MBP system. Any change? Nope!

    So, currently... the airport is coloured in as though it's connected to the network, however is not. In network preferences the 'airport' status is red and 'not connected'. There's nothing wrong with the home connection, I'm currently on it right now...

    so what the flip is going on with this brand new macbook pro... not amused!

    Appreciate any suggestions, cheers!

  2. #2
    Brand new MBP out the box, but...no airport connection???

    Member Since
    Mar 09, 2011
    Posts
    751
    Specs:
    mbp 15 2009, mbp 13 2010
    Quote Originally Posted by jhaime View Post
    It refuses to connect to my router! **** frustrating, any help is most appreciated.

    I've purchased the latest 15", quad core, 500GB blah blah...

    Took it out the box, pressed on, took me through all the mandatory language settings and keyboard settings, asked to connect to a network, popped in the relative password for our home network. Ok, sorted I assumed.

    Not to be...

    Initially it was coming up with an exclamation mark across airport and the message 'no internet connection' when you click to see what the deal is...

    So I clicked no internet connection, it took me through the alternatives of DHCP and the other.. used the other to pop in the account name and WAP code to establish the network. Hasn't worked, although has removed the exclamation mark.

    So, still no connection, attempted to turn my airport off on this system (imac), rebooted the router, nothing, nada... MBP still won't connect. So I look up this issue with airport... I tried deleting my home network (that it is actually 'connecting' to with a tick) in keychains, same in the advanced network preferences, re-load the MBP system. Any change? Nope!

    So, currently... the airport is coloured in as though it's connected to the network, however is not. In network preferences the 'airport' status is red and 'not connected'. There's nothing wrong with the home connection, I'm currently on it right now...

    so what the flip is going on with this brand new macbook pro... not amused!

    Appreciate any suggestions, cheers!
    the other alternate will be to take your mbp to apple store and have them look at it.

    or take it to the local wifi spot such as library and connect there see if it works.

  3. #3
    Brand new MBP out the box, but...no airport connection???
    jhaime's Avatar
    Member Since
    Feb 01, 2009
    Posts
    13
    ye, will try my brothers network tomorrow.. it's picking up other networks just fine, but they're password protected.

    The airport and airport settings are diagnosed as working fine, yet even though it registers the home network, ticks onto it, rejects incorrect passwords for it and everything, it won't connect to the isp and therefore internet fails. Yet I'm using the same network right now on my imac, it's bewildering!

    Just wondered if anybody knew what the trick was... or if in fact there's some random firewall on the router keeping me out... something terribly strange going on!

  4. #4
    Brand new MBP out the box, but...no airport connection???
    schweb's Avatar
    Member Since
    Oct 27, 2002
    Location
    Cleveland, Ohio
    Posts
    13,190
    Specs:
    MacBook Pro | LED Cinema Display | iPhone 4 | iPad 2
    What type of router do you have? What type of security is turned on? etc.
    schweb | community leader
    flickr facebook twitter tumblr google+ about.me

    Mac-Forums: On Twitter | On Facebook | On Flickr


  5. #5
    Brand new MBP out the box, but...no airport connection???
    Deckyon's Avatar
    Member Since
    Apr 06, 2011
    Location
    Louisville, KY - USA
    Posts
    1,291
    Specs:
    MBP 17" 2011, 2.3GHz Intel Quad-Core i7, 8GB RAM, MacMini 2011, 2.7GHz Intel Dual-Core i7, 8GB RAM
    Bounce the router.
    MBP 17" 2011, 2.3GHz Intel Quad-Core i7, 8GB RAM, AMD Radeon HD 6750M 1GB RAM
    MacMini 2011, 2.7GHz Intel Dual-Core i7, 8GB RAM, AMD Radeon HD 6630M 256MB RAM
    iPhone 5S 64GB, iPad Air 2 128 GB LTE, iPod Nano Gen6 8GB, Apple TV 3 & 2

  6. #6
    Brand new MBP out the box, but...no airport connection???

    Member Since
    Apr 19, 2011
    Location
    Virginia
    Posts
    35
    Specs:
    Early 2011 MBP i5 2.3GHz 13" 8Gb Ram 120Gb SSD
    Same thing happened to me when I tried to set up my new MBP (I'm a first time Mac user). After several hours of frustration, I realized my stupidity. When I set up my wireless network over a year ago, I enabled MAC address filtering. Since my new MBP was not on the filtering "whitelist", it wouldn't let me connect. Once I added it to the "whitelist", connected with no problem.

    Doubt that this is your problem, but just in case . . .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Brand new Out-of-the-box Macbook not working?
    By dennyc123 in forum Apple Notebooks
    Replies: 4
    Last Post: 02-06-2015, 04:01 PM
  2. Damage on brand new MBP (out of the box)
    By martinielsen in forum Apple Notebooks
    Replies: 14
    Last Post: 08-13-2009, 09:03 PM
  3. MBP/Airport has lost connection to wireless router
    By dmag in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 08-06-2008, 12:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •