Results 1 to 6 of 6
  1. #1
    HDD Won't Show on Setup - Not Always

    Member Since
    Nov 25, 2010
    Posts
    5
    HDD Won't Show on Setup - Not Always
    Hello. Here is my problem. Its a weird problem really. One day I powered my Macbook and I was getting a folder with a question mark. I opened the bottom case and checked. Everything seemed fine. I disconnected the hdd and I tested it on another computer. The HDD seemed 100% fine. But for some reason my Macbook wouldn't see the operating system. I disconnected again and formatted and connected again. But it would take forever to boot the Snow Leopard DvD. After booting it wouldn't see the hard drive. After I remove the RAM and power up again and I boot my Windows dvd. It sees the hard drive and I was able to install Windows perfect. I go to sleep and in the morning again it shows the folder with the question mark. Of course I tried another 2 hard drives and another Ram. Everything I tried came up with the same problem. 1 in 10 times it would find the hard drive. Every time it found the hard drive I wasn't able to unmount it through disk utility in Snow Leopard Setup. At one time it wouldn't find the hard drive for 50 consecutive times. Then I load Ubuntu Live cd and I could see the hard drive perfect! I restart and it would say "Disk error blah blah blah", an error from my Windows Installation. I try again Ubuntu Live cd and again I can see the hard drive. I try to install ubuntu but I get an error while formatting. Any suggestion would be perfect. I think it might be the hard drive cable that's causing all the problems. That's what I have tried so far :

    1. Resetting the NVRam.
    2. Tried 3 Hard Drives. All same problem.
    3. Tried 3 different Ram. All same problem.
    4. Tried installing Ubuntu in the external hard drive and then placing inside the Macbook. Wouldn't boot
    5. Tried repairing Hard Drive through Snow Leopard when I could see it. Wouldn't repair, it gave an error.

  2. #2
    HDD Won't Show on Setup - Not Always
    s2odin's Avatar
    Member Since
    Oct 23, 2010
    Posts
    836
    Specs:
    C2D 2.26 | 500GB Seagate Momentus | 2GB 1066 (soon to be 8)
    Quote Originally Posted by benzidirk View Post
    Hello. Here is my problem. Its a weird problem really. One day I powered my Macbook and I was getting a folder with a question mark. I opened the bottom case and checked. Everything seemed fine. I disconnected the hdd and I tested it on another computer. The HDD seemed 100% fine. But for some reason my Macbook wouldn't see the operating system. I disconnected again and formatted and connected again. But it would take forever to boot the Snow Leopard DvD. After booting it wouldn't see the hard drive. After I remove the RAM and power up again and I boot my Windows dvd. It sees the hard drive and I was able to install Windows perfect. I go to sleep and in the morning again it shows the folder with the question mark. Of course I tried another 2 hard drives and another Ram. Everything I tried came up with the same problem. 1 in 10 times it would find the hard drive. Every time it found the hard drive I wasn't able to unmount it through disk utility in Snow Leopard Setup. At one time it wouldn't find the hard drive for 50 consecutive times. Then I load Ubuntu Live cd and I could see the hard drive perfect! I restart and it would say "Disk error blah blah blah", an error from my Windows Installation. I try again Ubuntu Live cd and again I can see the hard drive. I try to install ubuntu but I get an error while formatting. Any suggestion would be perfect. I think it might be the hard drive cable that's causing all the problems. That's what I have tried so far :

    1. Resetting the NVRam.
    2. Tried 3 Hard Drives. All same problem.
    3. Tried 3 different Ram. All same problem.
    4. Tried installing Ubuntu in the external hard drive and then placing inside the Macbook. Wouldn't boot
    5. Tried repairing Hard Drive through Snow Leopard when I could see it. Wouldn't repair, it gave an error.
    Same thing happened to my friend.

    His ended up being a bad SATA cable connecting the HD to the mobo. Try that.
    USAF E-2. 1C6X1 - Space Systems Operations. 19 days until BMT.
    Upgrade your MBP HD
    Tritton AXPro FS

  3. #3
    HDD Won't Show on Setup - Not Always
    Buzzard2010's Avatar
    Member Since
    Oct 22, 2010
    Location
    Bretforton, Worcestershire
    Posts
    2,571
    Specs:
    MacBook Pro 15" 2014, 2.2GHz i7, 16GB RAM, 250GB SSD, OSX 10.9.5 - iPhone 5s 16gb
    Welcome to Mac-Forums
    Boot from your OSX disk and try repairing the disk/ disk permissions, worth a try but like you say sounds like a cable problem from what you have ruled out.

    - Simon

    If you have been helped, don't forget to use the Reputation system at the top right of their post.
    May 2011
    Nominated: March 2011 & April 2011

  4. #4
    HDD Won't Show on Setup - Not Always

    Member Since
    Nov 25, 2010
    Posts
    5
    I can't repair the hard drive as it's taking forever to load the hard drive information and then it does not give me the option to repair and verify. I can only erase the hard drive and then it's unmounting the hard drive for about 2 hours.

  5. #5
    HDD Won't Show on Setup - Not Always
    s2odin's Avatar
    Member Since
    Oct 23, 2010
    Posts
    836
    Specs:
    C2D 2.26 | 500GB Seagate Momentus | 2GB 1066 (soon to be 8)
    see my post above...
    USAF E-2. 1C6X1 - Space Systems Operations. 19 days until BMT.
    Upgrade your MBP HD
    Tritton AXPro FS

  6. #6
    HDD Won't Show on Setup - Not Always

    Member Since
    Nov 25, 2010
    Posts
    5
    Ok. I will try the cable. But when I search I find a cable #Apple Part #: 922-9062 and mine is #Apple Part : 821-0814. Is the 1st one compatible with my Macbook?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My HDD doesn't show only in my Imac
    By krizard in forum OS X - Operating System
    Replies: 3
    Last Post: 01-08-2013, 04:26 AM
  2. Why won't my External HDD's show up?
    By TwoToneAlex in forum Apple Notebooks
    Replies: 4
    Last Post: 05-11-2010, 08:51 PM
  3. HDD won't show!?
    By da9920 in forum Apple Desktops
    Replies: 1
    Last Post: 01-07-2010, 03:16 PM
  4. Dock won't show up, side window in finder windows won't be modified
    By Maiana in forum OS X - Operating System
    Replies: 1
    Last Post: 08-05-2008, 09:11 AM
  5. Have HDD show up on network w/AE
    By Sniper78 in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 03-15-2007, 09:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •