Results 1 to 4 of 4

Thread: 17" powerbook

  1. #1
    dlisle20
    Guest
    Unhappy 17" powerbook
    ive had my good old 1GHZ 17" pbook for 2 years now and only yesterday i closed the lid, opened it later and the computer wasn't on. I turned it on and the screen started showing odd colours and shapes. Later i turned it on and the screen didn't work. I then turned it on again and it started in open firmeware and said 'invalid memory access' and lots of wierd numbers. i shaked it a bit and i heard a rattle. i opened it in to discover a loose screw, i put it back in, same thing. i took out the RAM chip blew it put it back in, turned it back on, turned on normally and then a kernel panic. i blew the RAM again and turned it on and said 'invalid memory access' again. Can anyone explain this? do i need a new computer?

  2. #2
    17" powerbook
    Macman's Avatar
    Member Since
    Oct 30, 2004
    Location
    San Antonio, Texas
    Posts
    4,374
    Specs:
    PowerMac G4 Cube 450mhz 832mb
    have you tried booting without that ram chip in at alll? it may be bad ram, is it new?
    even if its not, it could go bad.

  3. #3
    jessica
    Guest
    yeah I would for sure remove that ram and boot again.

  4. #4
    dlisle20
    Guest
    Quote Originally Posted by Macman
    have you tried booting without that ram chip in at alll? it may be bad ram, is it new?
    even if its not, it could go bad.
    its the RAM which came with it, and i did take it out and turn it on but it still didn't work

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •