Results 1 to 5 of 5
  1. #1
    I broke something

    Member Since
    Dec 04, 2008
    Posts
    3
    I broke something
    I recently popped open my macbook pro 2.33 and attempted to replace a very loud right-side fan array. All went smoothly until I gently removed the power connector foot from the logic-board, along with the wires attached to the fan.
    It looks as if the soldering or glue or whatever gave way and is now destroyed. Can this be replaced somehow? or should i continue to run with out the fan? So far it has been fine, and not overheating, in fact the other side barely runs faster then 1900 rpm. Any ideas? I really dont want to take this in anywhere

    thx

  2. #2
    I broke something
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,291
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    You really need to get that fan running. Over time the heat build up may do damage costing you more in the long run. The connector you tried removing "gently" from the logic board can probably be repaired with the proper tools.

    Normally wires that go into that type of connector have small metallic clip ends which slide into the openings and lock in place. It's possible when you pulled on the connector the wires came loose from the metal clips. More than likely the clips are still in the connector. The best way to remove those types of connectors is by gently prying them upward away from the board with a small flat plastic tool.

    Anyway, consider repairing it. You may be able to do it yourself or find someone who is proficient at doing that type of work.

    Regards.

  3. #3
    I broke something
    ViriiGuy's Avatar
    Member Since
    Feb 15, 2008
    Location
    Knoxville Tn.
    Posts
    173
    Specs:
    15" MacBook Pro | 2.8Ghz C2D | 4 Gigs Ram | 512 Meg 9600 GT | 320 Gig Hdd
    If you could take a clear picture of the damage, I could answer it for you pretty quickly.

  4. #4
    I broke something

    Member Since
    Dec 04, 2008
    Posts
    3
    well the little black clip or shoe is snapped in 2 and the little teeth are long gone, I basically need another lil clip, but i have no idea what was holding it in place. It wasnt soldered, because it was plastic, do they use glue? I dont know if the clip was defective, I twisted it, or it had degraded over time.

    thanks for the replies

  5. #5
    I broke something

    Member Since
    Dec 04, 2008
    Posts
    3
    little power connector shoe?
    Anyone know where I can find the small little part described above?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. It Broke!!! ;(
    By Atrox in forum Apple Notebooks
    Replies: 26
    Last Post: 11-01-2007, 01:34 AM
  2. iPod broke PC?
    By kaidomac in forum iPod Hardware and Accessories
    Replies: 29
    Last Post: 03-18-2007, 11:47 AM
  3. Help!!!... I broke It!!
    By Basket_Case_24 in forum OS X - Operating System
    Replies: 1
    Last Post: 12-04-2005, 03:40 AM
  4. HELP! I broke it!
    By normal1 in forum Switcher Hangout
    Replies: 7
    Last Post: 11-19-2005, 01:54 PM
  5. I broke it!
    By sKaD in forum Web Design and Hosting
    Replies: 3
    Last Post: 09-27-2003, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •