Results 1 to 9 of 9
  1. #1
    Ram installation problem

    Member Since
    Jun 07, 2006
    Location
    NYC
    Posts
    288
    Specs:
    Intel iMac 20" Core Duo 256mb VRam 115gb SSD 2gb Ram Finally!!!
    Ram installation problem
    I have an older Intel 20" iMac, mid 2006 model (is that really older?). It came with the standard 512mb since I took everyone's advice and didn't order more from Apple.

    I tried to add another 1gb to it last year but couldn't get it to work, so I just gave up on it and I figured it was a bad stick. I tried installing it multiple times, swapped the slots, cleaned the contacts. I would just get a fast flash on restart. It isn't like I do a lot on it anyway, mostly surf and iTunes. My son however is turning into quite the musician and was complaining about it sometimes being a little slow when recording.

    Yesterday, my 2 new samsung 1gb sticks arrived and I tried installing them both. Same thing, a fast flash. I pulled the lower stick out and tried that and it worked, so now I'm up to 1gb in the machine and it does seem faster and more responsive, particularly with MS Word/Excel, which aren't native.

    My question is what to try next? I'm beginning to think that one slot has a problem, or maybe I'm doing something wrong? Any advice? (my system spec is wrong on my profile, I never got the extra to work.)

  2. #2
    Ram installation problem
    Chilbear's Avatar
    Member Since
    Jun 14, 2007
    Location
    Toronto
    Posts
    574
    Specs:
    2xiMac24 w Parallels 6 (1x White, 1x Aluminum), iPhone 3GS with iOS5
    Maybe backing up and trying something to sleuth the problem.

    You said the 1 x512 stick and 1x1gb worked. Have you tried the 512 stick in the other slot all by itself? If it flashes/fails then yes the slot looks to be the issue. If not leave it there and put the 1gb stick in. If they fail then my best guess is the computer firmware is confused.

    Last solution is to return the 2x1gb you bought and get 1x2 and install it in the one good slot.

  3. #3
    Ram installation problem

    Member Since
    Jun 07, 2006
    Location
    NYC
    Posts
    288
    Specs:
    Intel iMac 20" Core Duo 256mb VRam 115gb SSD 2gb Ram Finally!!!
    My understanding is that this particular model will only work with 1gb sticks, one in each slot.

    Anyway, I tried using other combinations, and the only two that have worked so far is the original 512 in the top slot, and the new 1gb in the top slot. The older 1gb stick did not work, nor does anything work in the bottom slot.

    I haven't had a chance to try again, so I'll try all the combinations. This computer gets heavy use even if only for music and surfing. I can't wrest it away from my wife and kids.

  4. #4
    Ram installation problem
    Chilbear's Avatar
    Member Since
    Jun 14, 2007
    Location
    Toronto
    Posts
    574
    Specs:
    2xiMac24 w Parallels 6 (1x White, 1x Aluminum), iPhone 3GS with iOS5
    Can you see the memory/slots from System Profiler? You should be able to see each slot and what is in it.

  5. #5
    Ram installation problem
    rhcpcjg's Avatar
    Member Since
    Oct 24, 2007
    Posts
    12
    I would say its a bad slot, ram rarely goes bad... call apple if you still have warranty or if you purchased apple care.

  6. #6
    Ram installation problem
    Alexis's Avatar
    Member Since
    Apr 20, 2006
    Posts
    2,255
    Specs:
    Al iMac 20" 2.4Ghz Intel Core 2 Duo
    My understanding is that this particular model will only work with 1gb sticks, one in each slot.
    No, that's incorrect. Put the 512 meg stick in the 'faulty' slot. It should recognise it.

  7. #7
    Ram installation problem

    Member Since
    Jun 07, 2006
    Location
    NYC
    Posts
    288
    Specs:
    Intel iMac 20" Core Duo 256mb VRam 115gb SSD 2gb Ram Finally!!!
    Yes, of course the 512 still works too. I meant the upper limit was the 1gb.

    I haven't had a chance to try anything else yet. I did buy Apple care so if it is a bad slot they can take care of it.

    The problem with using system profiler is that the computer has to boot up to use it. With bad memory it doesn't boot.

  8. #8
    Ram installation problem

    Member Since
    Jun 07, 2006
    Location
    NYC
    Posts
    288
    Specs:
    Intel iMac 20" Core Duo 256mb VRam 115gb SSD 2gb Ram Finally!!!
    I've had a chance to play around with it and I can't get anything to work in slot 0, the lower slot when it is laying on the face. The upper slot takes anything I put in it.

    I guess it is the slot then, and my next stop is the Apple store in Soho.

  9. #9
    Ram installation problem

    Member Since
    Dec 01, 2007
    Posts
    1
    Just today I'm trying to add 2, 1gb sticks to my 2004 iMac. I'm getting the exact problem that you are. (i.e., one stick works, two sticks don't work) I'd be interested to know if your slot ends up being the culprit.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ram installation
    By daviejon in forum OS X - Operating System
    Replies: 6
    Last Post: 12-25-2012, 03:26 PM
  2. Not picking up RAM after installation
    By darcat23 in forum Apple Desktops
    Replies: 1
    Last Post: 06-13-2009, 12:18 AM
  3. No Display after Ram Installation
    By kel4488 in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 04-19-2009, 05:31 PM
  4. ram installation guide
    By Scatman in forum Apple Notebooks
    Replies: 3
    Last Post: 07-11-2006, 08:35 AM
  5. My RAM installation adventure
    By Americain in forum Switcher Hangout
    Replies: 3
    Last Post: 04-06-2006, 07:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •