Results 1 to 6 of 6
  1. #1
    justinkelly
    Guest
    Angry iMac 350 dead after install of panther
    Hi All

    I just attempted to install OS10.3 on my iMac G3 350, when installing a message popped up stating that my firmware needed to be uprgraded I click OK, a few minutes of an install screen doing nothing the screen when black, now when i turn on my imac all that appears in a black screen and after a few seconds the imac turns off???? I have taken the HD out and put it in my G4 400 and it booted now worries (into OSX.1) , now what?

    Cheers

    Any help would be greatly appreciated

    Justin

  2. #2
    iMac 350 dead after install of panther
    D3v1L80Y's Avatar
    Member Since
    Feb 02, 2004
    Location
    PA
    Posts
    12,456
    Specs:
    MacBook
    Quote Originally Posted by justinkelly
    Hi All

    I just attempted to install OS10.3 on my iMac G3 350, when installing a message popped up stating that my firmware needed to be uprgraded I click OK, a few minutes of an install screen doing nothing the screen when black, now when i turn on my imac all that appears in a black screen and after a few seconds the imac turns off???? I have taken the HD out and put it in my G4 400 and it booted now worries (into OSX.1) , now what?

    Cheers

    Any help would be greatly appreciated

    Justin
    I installed Panther on my imac DV SE 400 with no worries. In order for the firmware update to complete correctly you should boot from OS 9 to apply it. These articles from the Apple support site may help you

    http://docs.info.apple.com/article.html?artnum=60385

    http://docs.info.apple.com/article.html?artnum=75130
    __________________________________________________
    Posting and YOU|Forum Community Guidelines|The Apple Product Cycle|Forum Courtesy

    mac: a waterproof raincoat made of rubberized fabric
    MAC: a data communication protocol sub-layer, also known as the Media Access Control
    Mac: a brand name which covers several lines of personal computers designed, developed, and marketed by Apple Inc.


  3. #3
    iBob
    Guest
    Wink
    This is a common occurance just hope you have a second monitor port at the rear. Plug in another monitor it should then boot then download the firmware upgrade from the mac.com. Follow the instructions and all should be well with the world. However if you have no monitor port life will get very complicated requiring a copy of timbuktu software and a couple of modems to allow the upgrade to be done remotely. If you have any problems getting the upgrade let me know can e-mail it

  4. #4
    justinkelly
    Guest
    Question iMac still dead
    Thanks iBob andD3v1L80Y for your replies but im still having no luck with my iMac,

    What i did do was that as i dont have a second monitor port as the rear of my iMac or a copy of timbuktu i pulled the HD out and put it in my G4 PowerMac, installed the new apple firmware (could only install the G4 PM version), install Panther and everything looks fine when the HDs in the PowerMac but when I put it back in the iMac 350 all i get is a blank screen - when i turn on my iMac it sounds likes its booting up OK now but the screen remains black (no aplple symbol, nothing) ?

    Whats now?

    Thanks again for all your help

    Cheers

    Justin



    Quote Originally Posted by iBob
    This is a common occurance just hope you have a second monitor port at the rear. Plug in another monitor it should then boot then download the firmware upgrade from the mac.com. Follow the instructions and all should be well with the world. However if you have no monitor port life will get very complicated requiring a copy of timbuktu software and a couple of modems to allow the upgrade to be done remotely. If you have any problems getting the upgrade let me know can e-mail it

  5. #5
    iBob
    Guest
    Question
    Quote Originally Posted by justinkelly
    Thanks iBob andD3v1L80Y for your replies but im still having no luck with my iMac,

    What i did do was that as i dont have a second monitor port as the rear of my iMac or a copy of timbuktu i pulled the HD out and put it in my G4 PowerMac, installed the new apple firmware (could only install the G4 PM version), install Panther and everything looks fine when the HDs in the PowerMac but when I put it back in the iMac 350 all i get is a blank screen - when i turn on my iMac it sounds likes its booting up OK now but the screen remains black (no aplple symbol, nothing) ?

    Whats now?

    Thanks again for all your help

    Cheers

    Justin

    Justin
    The firmware upgrade is actully sent to the chip that drives the monitor and is not a software upgrade that resides on the disc. The G4 upgrade you did will only have worked for the G4. If you can find some one that has not done a firmware upgrade on there imac or G3 and borrow the disc you will then be able to do yours. The upgrade has to be done from the boot disc. Hope this helps.

  6. #6
    Delomar
    Guest
    Ah!
    I'm having the exact same problem, and nothing seems to be working. Is it possible to upgrade the formware some other way?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dead iMac after SSD install
    By waxinjaxin in forum Apple Desktops
    Replies: 4
    Last Post: 08-19-2012, 12:58 PM
  2. B&W G3 350 - Installing 120 gig with OSX Panther
    By powercat in forum Apple Desktops
    Replies: 3
    Last Post: 12-28-2004, 11:32 PM
  3. g4 350/256 struggling with clean install 9.2.1
    By paranoidjack in forum Apple Desktops
    Replies: 1
    Last Post: 11-12-2004, 06:39 PM
  4. iMac 350-G3 + Panther 10.3.2 hangs
    By advisor in forum Apple Desktops
    Replies: 0
    Last Post: 02-29-2004, 07:02 AM
  5. iMac 350-G3 + Panther 10.3.2 hangs
    By advisor in forum Apple Desktops
    Replies: 0
    Last Post: 02-29-2004, 06:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •