Results 1 to 5 of 5
  1. #1
    USB port problem
    pastelado's Avatar
    Member Since
    Apr 01, 2011
    Location
    caracas
    Posts
    10
    Specs:
    imac 5.1
    Post USB port problem
    Hello, i recently made a huge mistake. I bought a universal power source, you know the one that allows you to change the voltage and such. and it came with little adapters to mach the device youre going to use.

    well i screw up, big time!, i connected a USB hub to the power source but i think i change the polarity, you know, the - and +, and it damage one usb flash drive, one portable HDD and 2 out 3 usb ports of my imac.

    i know it was a stupid mistake, and probably damage the ports in my imac. Does anyone can help me?

    please!

    sorry about my english BTW

    my imac specs:

    Hardware Overview:

    Model Name: iMac
    Model Identifier: iMac5,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 4 MB
    Memory: 2 GB
    Bus Speed: 667 MHz
    Boot ROM Version: IM51.0090.B09
    SMC Version (system): 1.8f2
    Serial Number (system): W86477C5VUX
    Hardware UUID: 00000000-0000-1000-8000-0017F2C68FD3

  2. #2
    USB port problem
    louishen's Avatar
    Member Since
    Oct 22, 2007
    Location
    London
    Posts
    8,968
    Specs:
    Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver
    sounds like you are down to one working usb port

    you are going to have to use a hub to connect your stuff from now on, and avoid mucking around with the electrical supply to your devices

    you could try resetting the power management but it may not help

    http://osxdaily.com/2010/03/24/when-...ontroller-smc/
    Member of the Month September 2008 & August 2012 | Found advice useful? use the rep system

  3. #3
    USB port problem
    pastelado's Avatar
    Member Since
    Apr 01, 2011
    Location
    caracas
    Posts
    10
    Specs:
    imac 5.1
    Quote Originally Posted by louishen View Post
    sounds like you are down to one working usb port

    you are going to have to use a hub to connect your stuff from now on, and avoid mucking around with the electrical supply to your devices
    yes, thats what im doing, but the port that works wont even reads a portable HDD, its like's working at 50%.

    Can i replace that damage module of the imac? the one with all the ports... i know i can do it myself if it is possible...

    what do you think?
    The past is a construct of the mind... the heart wants to live in the present

  4. #4
    USB port problem

    Member Since
    Apr 24, 2009
    Location
    UK
    Posts
    593
    Specs:
    MacBook Pro 15" 2.8 GHz
    Your only fix would be to replace the logic board. These are no longer available from Apple as your iMac is classed as vintage. The Late 2006 17" iMac is old now, it wouldn't be economically viable to fit even a used logic board unless you got it very cheap.
    Steve
    UK

  5. #5
    USB port problem
    pastelado's Avatar
    Member Since
    Apr 01, 2011
    Location
    caracas
    Posts
    10
    Specs:
    imac 5.1
    Quote Originally Posted by techiesteve View Post
    Your only fix would be to replace the logic board. These are no longer available from Apple as your iMac is classed as vintage. The Late 2006 17" iMac is old now, it wouldn't be economically viable to fit even a used logic board unless you got it very cheap.
    many thanks!
    The past is a construct of the mind... the heart wants to live in the present

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weird problem with one usb port.
    By opp in forum OS X - Operating System
    Replies: 0
    Last Post: 09-12-2013, 05:45 AM
  2. Mac USB Port Problem
    By Naff47 in forum OS X - Operating System
    Replies: 3
    Last Post: 04-04-2012, 02:24 PM
  3. Problem with one of the usb port
    By iggibar in forum Apple Notebooks
    Replies: 4
    Last Post: 10-30-2009, 03:57 PM
  4. USB Port problem
    By classicmds in forum Apple Desktops
    Replies: 3
    Last Post: 07-14-2009, 07:56 PM
  5. Replies: 3
    Last Post: 04-18-2009, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •