Results 1 to 4 of 4
  1. #1
    Running a 9800GTX+ in an Early 2008 Mac Pro

    Member Since
    Apr 25, 2012
    Posts
    2
    Running a 9800GTX+ in an Early 2008 Mac Pro
    (I posted this in another section of this forum, but I don't think it posted correctly, so I'm putting this in the hardware section instead, since that's probably where it belongs. If it shows up in the other section eventually, it can be deleted).

    I recently came into possession of an Early 2008 Mac Pro (2x2.8GHz Zeon model). I've installed OS X 10.6, and might use it every once in a while...but my goal is to install Windows 7 on it and use it as a development/gaming machine.

    The box came with the ATI 2600 it shipped with, and I have a GeForce 9800GTX+ that I would like to use. I'd like to know the best way to get this going, so I have a few questions.

    Before the questions, though, some facts:
    • I have successfully installed OS X 10.6, with all updates
    • The ATI 2600 is in the first PCI slot, and it works fine.
    • When I have the 9800GTX+ in the second PCI slot, it doesn't work in OS X, it's listed as a video card or something.
    • I know the 9800GTX+ won't work on the Mac side, I'm fine with that.
    • I used bootcamp to install Windows 7 32-bit, and after the installer finished it just sat at a black screen for a loooong time
    • After turning the machine off, removing the GeForce 9800GTX+, and restarting, the Windows installation completed.


    So the questions:
    • Is the correct order of events:

    1. Only have the 2600 in the machine
    2. Install OS X
    3. Run Bootcamp
    4. Install Windows
    5. Run the Bootcamp driver setup in from the OS X disk from within Windows
    6. Shutdown the machine and put the 9800GTX+ in
    7. Start back up, finish updates, etc?
    • Should I be concerned that with the 9800GTX+ in the machine I was getting a black screen? Or is that normal, and does the installation of the Bootcamp drivers resolve that?
    • Or to put it another way: Should I wait to put the non-OS X compatible GPU in until after I've gone through the Windows install and updated everything?
    • Can I switch the placement of the 2600 from the first PCI slot to the second, or will that confuse OS X? I want to switch the current location of the cards for better airflow

    One last question: I installed Win7 32-bit, and only see 1.99GB on the Windows side. From what I've read, if I install the 64-bit version of Win7 I'll see all my installed RAM. Again, this is an early 2008 Mac Pro, so I think the issue is the EFI thingie.

  2. #2
    Running a 9800GTX+ in an Early 2008 Mac Pro
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    20,025
    Specs:
    iMac i5 2.7GHz, 16GB memory, OS 10.10.5
    G'day and welcome to the forums.

    Always pays to do a search of your subject:-


    http://www.mac-forums.com/forums/app...-possible.html

    Windows 32bit install will only show the 1.99GB. As your Mac Pro has is 64bit just use the Windows 64bit disc.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  3. #3
    Running a 9800GTX+ in an Early 2008 Mac Pro

    Member Since
    Apr 25, 2012
    Posts
    2
    Quote Originally Posted by harryb2448 View Post
    G'day and welcome to the forums.
    Thanks.

    Quote Originally Posted by harryb2448 View Post
    Always pays to do a search of your subject:-


    http://www.mac-forums.com/forums/app...-possible.html
    Always pays to actually read an entire post: I'm not interested in getting the 9800 working in OS X, and I had seen that post but it didn't apply to what I was trying to do.

    Anyway, I have everything working. I installed Win7, installed bootcamp drivers, installed the NVidia driver, then rebooted and it worked.


    Quote Originally Posted by harryb2448 View Post
    Windows 32bit install will only show the 1.99GB. As your Mac Pro has is 64bit just use the Windows 64bit disc.
    Yep, installed 64-bit Win7, and I see all 4GB!

  4. #4
    Running a 9800GTX+ in an Early 2008 Mac Pro
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    20,025
    Specs:
    iMac i5 2.7GHz, 16GB memory, OS 10.10.5
    The card will work on the Mac side and also the Windows 7 side.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. USB3 for Mac Pro 3.1 (early 2008)
    By Wangiboy in forum OS X - Operating System
    Replies: 2
    Last Post: 12-01-2014, 06:35 PM
  2. Early 2008 Mac Pro won't power up
    By kevvo in forum Apple Desktops
    Replies: 8
    Last Post: 07-15-2012, 11:01 PM
  3. Mac Pro (Early 2008 Model) boots itself up...please help!
    By orchestranova in forum Apple Desktops
    Replies: 6
    Last Post: 06-16-2011, 01:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •