Results 1 to 5 of 5

Thread: Can't eject from keyboard

  1. #1

    Member Since
    Jul 05, 2008
    Your Mac's Specs
    G5 PPC Dual 2 gig 6gig ram 10.5.3 and a G4 Mirror Door dual 1.25 2 gig ram
    Can't eject from keyboard
    HI All,
    Hopefully I'm in the right place, if this turns out to be a software issue, I'm sorry.
    PowerPC G5 dual 2 ghz, 2 x 500gig HDs, 6 gig ram running 10.5.8.
    PIONEER DVD-RW DVR-115D is the drive in question.
    All fine until 3 days ago then the eject button stopped working. I can see the eject icon and I can hear the drive "try" but it won't open. Strange thing is, it DOES open from Toast, or when after I've used a paper clip pin to manually eject to get a disc in, all burns OK, once burned I click the eject icon and it'll work. It's just from the keyboard eject. I have a wired system and tried on 3 different keyboards, all the same. I did try and update Firmware (it's the firmware it came with 4 years ago and I don't how to find out the version)whatever that is, but couldn't seem to find any update other than for Windows.
    It is VERY frustrating to have to manually eject to get a disk in every time you want to burn something. Any ideas other than GO TO SOFTWARE ;-) As it appeared to be a drive problem I thought I'd start here, apologies again if I'm wrong. Thanks.

  2. #2

    Member Since
    Feb 07, 2012
    It might be worth resetting the open firmware Slotype

    Hold down the cmd, option, o, f keys at startup the mac should boot into a white screen which should tell you your current firmware version. once on this screen/page type these commands with the dash but no spaces

    reset-nvram and hit return, then type
    reset-all and hit return

    The mac should reboot by itself with a nice clean open firmware, hope it does the trick

  3. #3

    Member Since
    Jul 05, 2008
    Your Mac's Specs
    G5 PPC Dual 2 gig 6gig ram 10.5.3 and a G4 Mirror Door dual 1.25 2 gig ram
    Thanks Hammer Time, did as you said, your instructions worked perfectly, but alas the drive still won't open from the eject button. Thanks again, appreciate the help. Is the DVD firmware a Pioneer thing or a Apple thing? I mean, does each component have a firmware from the manufacturer or is it a global one fits all on each individual system?

  4. #4

    cradom's Avatar
    Member Since
    Feb 14, 2004
    Groves, Texas
    Your Mac's Specs
    21in. iMac 10.11 --- HP Linux Mint 18
    This might be a hardware problem. I had an HP that did the same thing. Had to press the button several times on the drive to get it to open.
    I think it was a Pioneer drive too.
    Any priest or shaman must be presumed guilty until proved innocent.

  5. #5

    Member Since
    Jul 05, 2008
    Your Mac's Specs
    G5 PPC Dual 2 gig 6gig ram 10.5.3 and a G4 Mirror Door dual 1.25 2 gig ram
    Appreciate the input cradom, It's hard to find a new drive in England that will work on leopard on a non Intel Mac. I may have to suffer it until funds allow an upgrade to an Intel Mac.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't eject CD
    By Jhorra in forum Switcher Hangout
    Replies: 6
    Last Post: 11-12-2008, 08:50 AM
  2. no way to eject cd
    By fminmexico in forum Apple Desktops
    Replies: 10
    Last Post: 12-13-2007, 04:03 PM
  3. OSX Eject button on Keyboard
    By Liam in forum macOS - Operating System
    Replies: 19
    Last Post: 06-01-2007, 05:32 PM
  4. Eject DVD Drive with PC Keyboard
    By energylevel in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 04-21-2004, 04:04 PM
  5. CD tray eject with Apple USB Keyboard?
    By lokerd in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 11-18-2003, 04:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts