Results 1 to 6 of 6
  1. #1
    New iMac internet goes out after a few minutes

    Member Since
    Oct 09, 2011
    Posts
    1
    New iMac internet goes out after a few minutes
    Hello everyone, Last night I purchased ab iMac and joined your side. I love it, but am having a few issues. I am able to identify my home network and connect to it. After I connect to it, I have Internet access. However, after i leave and come back after 15 minutes or so the Internet no longer works. It shows I am still connected to the wireless network, but Internet pages fail to load. If I disconnect from the network and reconnect to it, the Internet works again but it's the same story over and over again.

    DHCP is enabled, and nothing else seems off. Obviously something is right because I have network and Internet access at first. Does the iMac have some weird settings I'm not seeing? I have searched forums and solutions but to no avail.

    Seems like Mac and I aren't getting off to a good start...

  2. #2
    New iMac internet goes out after a few minutes

    Member Since
    Dec 11, 2010
    Posts
    1,352
    Turn off iPv6 and PPPoE if these are on.

  3. #3
    New iMac internet goes out after a few minutes

    Member Since
    Sep 10, 2011
    Location
    Colne,UK
    Posts
    1,748
    Specs:
    iMac 27" Mid 2010, 3.2GHz Intel Core i3,12GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Yose 10.10.5
    There are known issues with 'sleep' mode disconnecting the wireless. There is lots of stuff on the internet about the issue because I have the same problem with a new iMac 27"..check what your time-out settings are in your preferences and adjust to a longer period if necessary. I have found that letting the machine find it's feet again for a while after waking up will re-connect.

    You can also try disconnecting and re-connect your wireless router via it's own portal..you need to find it's own ip address in your network settings and list it as a top site in Safari so that you can readily access it..I wouldn't recommend dropping the power to your wireless router on a regular basis although it does help to perform a reset occasionally.

    The router should also give you an option to do a firmware update, so do this as soon as possible.

    Also check your wireless router position, it needs to be as close to your machine as it can be or centrally at a high point to your dwelling.

    Apart from that it's a pain in the butt.
    iMac 27-inch Mid 2010 (wow....that old...eeeks!), WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
    iPhone 5C, iPod Nano 4GB 3rd Gen, ATV2.
    MOTM October 2012. These days normally happy with an occasional grumble.

  4. #4
    New iMac internet goes out after a few minutes

    Member Since
    Sep 10, 2011
    Location
    Colne,UK
    Posts
    1,748
    Specs:
    iMac 27" Mid 2010, 3.2GHz Intel Core i3,12GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Yose 10.10.5
    iMac disconnects from wireless - MacRumors Forums

    This link may help...I'm going to have a closer look at the WEP issue.
    iMac 27-inch Mid 2010 (wow....that old...eeeks!), WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
    iPhone 5C, iPod Nano 4GB 3rd Gen, ATV2.
    MOTM October 2012. These days normally happy with an occasional grumble.

  5. #5
    New iMac internet goes out after a few minutes
    Chef_eam's Avatar
    Member Since
    Dec 12, 2009
    Location
    Midland,Tx
    Posts
    357
    Specs:
    iMac 27" 2.66GHz i5, 1TB HDD, 12GB RAM, OS X 10.7.3, iPod Classic 160GB,iPad 1 64GB Wi-fi, iPhone 4S
    My iMac did the same thing when I first got it. I was using a Belkin N+ router at the time. When I purchased an Airport Extreme, the problem went away, and I have also never has a problem with it staying connected to a Linksys router.

  6. #6
    New iMac internet goes out after a few minutes

    Member Since
    Sep 10, 2011
    Location
    Colne,UK
    Posts
    1,748
    Specs:
    iMac 27" Mid 2010, 3.2GHz Intel Core i3,12GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Yose 10.10.5
    Quote Originally Posted by Chef_eam View Post
    My iMac did the same thing when I first got it. I was using a Belkin N+ router at the time. When I purchased an Airport Extreme, the problem went away, and I have also never has a problem with it staying connected to a Linksys router.
    Yes I had heard that certain wireless routers were Mac specific..mine's Belkin 54G and the firmware update is obsolete.
    iMac 27-inch Mid 2010 (wow....that old...eeeks!), WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
    iPhone 5C, iPod Nano 4GB 3rd Gen, ATV2.
    MOTM October 2012. These days normally happy with an occasional grumble.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iMac slows down after few minutes of being used
    By pepart in forum Apple Desktops
    Replies: 5
    Last Post: 06-25-2015, 10:32 PM
  2. Internet takes about 2 minutes after startup
    By jimmyb14 in forum OS X - Operating System
    Replies: 7
    Last Post: 11-05-2011, 04:24 PM
  3. iMac takes over 15 minutes to turn on.
    By extreme586 in forum OS X - Operating System
    Replies: 1
    Last Post: 08-04-2011, 06:38 PM
  4. Windows Xp Internet keeps disconnecting every 5 minutes, limited or no connectivity
    By yarjarrarr in forum Running Windows (or anything else) on your Mac
    Replies: 2
    Last Post: 08-13-2009, 01:43 AM
  5. Internet in bootcamp keeps disconnecting after about every 10 minutes
    By yarjarrarr in forum Running Windows (or anything else) on your Mac
    Replies: 3
    Last Post: 01-29-2009, 03:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •