Results 1 to 6 of 6
  1. #1


    Member Since
    May 08, 2011
    Posts
    11
    Unhappy iMac can't find internal hard drive on start up
    1st things 1st:


    Model Name: iMac
    Model Identifier: iMac4,1
    Processor Name: Intel Core Duo
    Processor Speed: 2 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache (per processor): 2 MB
    Memory: 2 GB
    Bus Speed: 667 MHz
    Boot ROM Version: IM41.0055.B08
    SMC Version: 1.1f5
    Serial Number: W860524PU2S


    In order to use this computer, it has started up by using my external hard drive, which is a 1tb MyBook. I upgraded to Snow Leopard, but before hand, I did a full back-up onto the MyBook. I did a clean install of the Snow Leopard, but never got around to backing up after the fact. It may have worked out for the best, because it was apparent once I had a problem, since the previous back-up was running os 10.4.11 and they look nothing alike.

    Here is what I have seen and done. Oddly enough, I can access all the files from the internal hard drive once the computer is up and running via the external. I can use, copy and save files from the internal, but it will not find it while starting up. Under system preferences, start up disk, the internal is no longer an option. I ran the disk utility about six different times uninterrupted. The following was the final outcome of the last attempt:

    "Verify and Repair disk “Main Drive”
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Incorrect number of thread records
    Checking multi-linked files.
    Checking Catalog hierarchy.
    Invalid volume directory count
    (It should be 160696 instead of 160457)
    Invalid volume file count
    (It should be 547519 instead of 544575)
    Checking Extended Attributes file.
    Checking volume bitmap.
    Checking volume information.
    Repairing volume.
    Rechecking volume.
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Incorrect number of thread records
    Checking multi-linked files.
    Checking Catalog hierarchy.
    Invalid volume directory count
    (It should be 160696 instead of 160457)
    Invalid volume file count
    (It should be 547519 instead of 544575)
    Checking Extended Attributes file.
    Checking volume bitmap.
    Checking volume information.
    Repairing volume.
    Rechecking volume.
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Incorrect number of thread records
    Checking multi-linked files.
    Checking Catalog hierarchy.
    Invalid volume directory count
    (It should be 160696 instead of 160457)
    Invalid volume file count
    (It should be 547519 instead of 544575)
    Checking Extended Attributes file.
    Checking volume bitmap.
    Checking volume information.
    Repairing volume.
    Rechecking volume.
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Incorrect number of thread records
    Checking multi-linked files.
    Checking Catalog hierarchy.
    Invalid volume directory count
    (It should be 160696 instead of 160457)
    Invalid volume file count
    (It should be 547519 instead of 544575)
    Checking Extended Attributes file.
    Checking volume bitmap.
    Checking volume information.
    The volume Main Drive could not be repaired after 3 attempts.

    Error: The underlying task reported failure on exit


    1 HFS volume checked
    1 volume could not be repaired because of an error
    Repair attempted on 1 volume
    1 volume could not be repaired "


    I tried starting up in "Safe mode" (holding "shift key" while starting up). but it still started using the external drive. I then unplugged the external drive (after shutting down) and started again just by pressing the power button, no keys held. I got a white screen with a big flashing grey folder w/ a question mark on it.

    My first thought is that my internal is shot, but that doesn't explain why I am able to access files from that drive after the computer is running. So, is my internal shot or not?


    Thank you for any and all input,
    Jody

  2. #2


    Member Since
    May 08, 2011
    Posts
    11
    Update
    Just going through the motions.

    I unplugged the external and tried to start up in Single user mode (command + "s") and saw the same grey flashing folder w/ the question mark in it.

    Plugged the external back in and started in Single user mode, ran the /sbin/fsck -fy and it gave me an all ok message. I am not particularly familiar with this in line command and can only assume what it is checking is the start up disk. Which in the case that it was run would have been the external. Which isn't the problem.

    Any other suggestions before I rename this computer "Junk" or "Trash"?

    Thanks,
    Jody

  3. #3

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    22,237
    Specs:
    Imac 27" Retina 5K, 512GB flash memory, 3.3GHz, 16GB memory, macOS Sierra beta.
    Sure sounds like the internal drive has tossed it in. Pop in your operating system disc, boot from that and see if you can get into Utilities and run repair Disk from there and see what is reported.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  4. #4


    Member Since
    Jun 07, 2006
    Location
    NYC
    Posts
    297
    Specs:
    Late 2015 27" iMac, 3.3ghz, M395 gpu, 2tb Fusion, 8gb
    I just had the same problem with the same machine, except that my drive made a clicking sound just to make sure I understood it was dead. However, when I tried it 2 weeks later after vacation, it started up again. I had already ordered an SSD to replace it so rather than take a chance on the old drive I replaced it.

    Let me tell ya, this thing screams now. I installed a 115gb OWC Mercury Extreme (just like HarryB above). I selected 40 apps to open and had them open simultaneously and it took maybe 10 seconds.

    I can't say that I'd recommend you do it yourself like I did unless you are comfortable working on electronics. Not that it is difficult, but you don't want to end up with a disassembled computer that you can't put back together. The main difficult parts are more mechanical than electrical anyway: Removing the cover and removing the shielding.

  5. #5


    Member Since
    May 08, 2011
    Posts
    11
    Thanks to both of you for the responses.

    @harryb2448, I booted from the SL disk, ran utilities and it was unable to repair. Copy/Paste did not work in this mode, so I copied down a few things that may be of interest or useful;

    Error message pop up window read "Disk utility stopped repairing "Main Drive". ("Main Drive" is the name of my internal.) Disk utility can't repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files"

    After pressing the "ok" button, I read through the details and among many other things it had this "Orphaned file hard link (id=117711)", there were 74 different numbers other than the "117711"

    Also this "Updating boot support partitions for the volume as required".


    I don't want to get too excited, but it seems to be telling me it just needs to be reformatted. The fact is that it seems to be able to be read, therefore seems to be working in some capacity. I guess I will give that a try.

    @Zacster, Is the drive you installed a better and less expensive route than just upgrading to a new computer? If so, Can you help w/ where you may have purchased yours and it's cost. I am pretty handy as a mechanical person so i don't think installing should be much of an issue for me. But, it would be nice to have a couple of tips if you were so inclined. I don't see any screws to be removed before removing the cover, so I suspect it pops off with some very special care in doing so.

    Thank You,
    Jody

  6. #6


    Member Since
    Jun 07, 2006
    Location
    NYC
    Posts
    297
    Specs:
    Late 2015 27" iMac, 3.3ghz, M395 gpu, 2tb Fusion, 8gb
    I bought my drive from Other World Computing - macsales.com. The have a whole array of SSD (Solid State Drives) in all sizes. Just so you know, these get expensive. The 115gb Mercury Extreme Pro 3D is what I bought and it is $195. You will also need an adapter bracket because these are 2.5" and the iMac takes 3.5" drives. Note also that this is SMALLER than your current drive, but you already have a 1tb external so the internal size isn't important. You'll want to put your OSX and apps on the internal and use the external for more static files, in particular music and video. In real time, music and video don't need the speed, only if you are editing/transcoding.

    There are tips on iFixit.com on replacing the drive, just make sure you use the right model as every iMac is different. There is also a video from Small Dog on youtube that is close, but not exactly the same (the 17" version from the same period.) The cover has torx screws on the bottom that needs a set of torx drivers. I think OWC has them too, and then the clips at the top are the hard part. They hold the front bezel on and don't want to release. You stick a credit card into the rear vent, and hope for the best.

    Internally the shielding is the difficult thing as it uses a very sticky adhesive around the LCD. Also, the torx screws holding the LCD in place are very deep. Just take it slow and careful. Replacing the drive is the easy part once it is opened. There's a thread on this forum from a few weeks ago that describes my process. Just search on my moniker. (actually, as of right now it is about 10 threads below this one.)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Internal hard drive for an iMac Model emc2133
    By donisgood in forum Other Hardware and Peripherals
    Replies: 4
    Last Post: 01-31-2015, 04:01 PM
  2. Can't find internal Hard Drive
    By NealF in forum Apple Desktops
    Replies: 2
    Last Post: 03-20-2012, 05:32 PM
  3. 24in iMac cannot see internal hard drive
    By Mpaler in forum Apple Desktops
    Replies: 1
    Last Post: 03-16-2012, 03:40 PM
  4. iMac 5,1 and a SATA II internal hard drive
    By vigeoh in forum Apple Desktops
    Replies: 2
    Last Post: 11-05-2010, 04:47 PM
  5. upgrading the internal hard drive in an old iMac
    By Conrad D in forum Apple Desktops
    Replies: 6
    Last Post: 05-06-2006, 08:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •