Results 1 to 7 of 7
  1. #1
    My iMac(early 2008) video display glitches, hard freezes, help!

    Member Since
    Jun 16, 2011
    Posts
    5
    My iMac(early 2008) video display glitches, hard freezes, help!
    UPDATE JUNE 17TH:

    The problem appears to be caused by the graphic card, the Nvidia Geforce 8800 GS.

    I found a thread with a lot of people talking about this problem:

    http://forums.macrumors.com/showthread.php?t=1085213


    Hello,

    This is the mac rumor forums history of my problem.

    A summary of all that would be that my imac has several graphic glitching, even after cleaning and updating the hard drive.

    I'm posting here to have the best chances to solve this problem.

    Thanks for your time and sorry for the long post!

    Dominic





    Jun 8, 2011, 02:19 AM #1
    domajean
    macrumors newbie


    Join Date: Jun 2011 My iMac(early 2008) video display glitches, hard freezes, help!

    --------------------------------------------------------------------------------

    Hello,

    I know this is a long thread, I apologize for that but this is a really urgent situation and I don't have much time to solve it. Thanks for your futur help and your time.

    I'm a video game sound designer and I use a lot my iMac for audio duties. This iMac(24 inch early 2008) running OSX 10.5 is a little more than 2 years old with an upgrade of 4 gig of ram I succesfully did 3 months ago. My apple care has ended.

    Not too long ago, I have experienced little slowdowns and freezes. I solved most of this issue by cleaning the files on the hard drive.

    Today, it was the 3rd day the iMac was running with no stop. I know, it's stupid from my part to have let this happen.

    While watching the E3 Nintendo press conference, all in the sudden the screen went completely white , no more sound. The only sound I hurd, was the hard drive...it was like spinning in the wind, with a little ''chick, chick,chick'' sound.

    I closed the machine. I opened it again 10 minute laters. The start seemed ok. I just did a get info on the HD to see how much space free there was and Boom! Big video glitches on the get info window and a complete freeze of the desktop. I closed the iMac for 1 hour, opened it again...and unplugged all the usb wires beside the keyboard....opened an audio software to see if it was capable of running any software...all seemed good...opened a song with itune...and there we go again! Big video bleeding everywhere, even worse than before with weird red lines all over the screen. At this point, I knew I had to do an up-to-date backup of my work before it goes more bad.

    Wow, now I'm in big troubles. It is not all dark, since I succeeded to export all my important work on my classic 80gig ipod(I don't have an external hard drive). But now I'm searching the forums and I'm trying to understand all the possibilities of this problem.

    At first, I was praticly ready to replace the hard drive in my iMac by following the different steps I saw on youtube...but after more deep net surfing I found that maybe the video card or the logic board was the cause of my problem.

    I have a lot of softwares and files that I want to save, so I thought about buying a SATA hard drive adapter:

    Other World Computing - U2NV2SPATA Item Not Found

    And use my old PC hard drive to back up all my OS. That said, I fear the possibility of cloning corrupted files...?

    The last time I opened the iMac, I wanted to show to my roomate the problem, and no issue appeared beside a little video glitch after opening itunes, firefox and neo office one after an other...but the iMac kind of fixed himself and after that no glitches were showing...the processus were a little slow, thought. After that, I shutted down the iMac.

    I still think it's an hard drive issue, but it could be so many things... I don't have a lot of money, for now, to spend on this problem. I don't want to send my iMac to Apple or anything and I want to be 100% sure of what is causing the issue so I can replace it myself without spending too much money.

    If anybody can help me with this, I would be more than grateful!

    Thank you for your time and consideration,

    Dominic

    --------------------------------------------------------------------------------
    Last edited by domajean; Jun 8, 2011 at 03:51 AM.
    0

    domajean
    View Public Profile
    Find More Posts by domajean
    Add domajean to Your Contacts

    Jun 8, 2011, 03:27 AM #2
    MacHamster68
    macrumors 68030




    Join Date: Sep 2009 if you got the optional nvidia geforce 8800 in your 24" it definitely is the GPU , if you got the basic GPU inside then its the harddrive
    __________________
    some pre intel Mac's
    DANGER POST MAY CONTAIN SARCASM
    Classic Mac • Index page
    0

    MacHamster68
    View Public Profile
    Find More Posts by MacHamster68
    Add MacHamster68 to Your Contacts

    Jun 8, 2011, 03:43 AM #3
    domajean
    Thread Starter
    macrumors newbie


    Join Date: Jun 2011 Hi MacHamster,

    Thanks for your fast answer! I have the basic GPU.

    That said, could you explain why in that case it would be the hard drive and not the video card.

    And if I backup all my OS and files on an external hardrive, does it has risk of duplicating the corrupted files(if there is any)?

    Thanks a lot!

    Dominic

    --------------------------------------------------------------------------------
    Last edited by domajean; Jun 8, 2011 at 03:53 AM.
    0

    domajean
    View Public Profile
    Find More Posts by domajean
    Add domajean to Your Contacts

    Jun 8, 2011, 04:31 AM #4
    MacHamster68
    macrumors 68030




    Join Date: Sep 2009 no i think if you got the the ati gpu and the ati is near bulletproof , just did want to eliminate the nvidia as source of the problem
    as you did not mention if the temps are alright or if your fans kick in big times after a while
    so first things first , you need to open the iMac definitely , so do it now and clean it inside , you will be surprised or shocked about the amount of dust inside , especially in between the fins of the GPU and cpu heatsink and on the fans , once cleaned and closed again , run the apple hardware test the extended version , that should find something
    i doubt corrupt files are responsible , but you can always repair permissions (could cause problems too if the permissions are not correct )
    replacing the harddrive after 4 years is a good idea anyway and they are not expensive really and your backup should be ok as you should be able to go back to the day before the issue started if not clean install and only get the files you need of the backup (eg. dokuments ,photos ,music , films and such)
    __________________
    some pre intel Mac's
    DANGER POST MAY CONTAIN SARCASM
    Classic Mac • Index page
    0

    MacHamster68
    View Public Profile
    Find More Posts by MacHamster68
    Add MacHamster68 to Your Contacts

    Jun 8, 2011, 04:43 AM #5
    domajean
    Thread Starter
    macrumors newbie


    Join Date: Jun 2011 Hello MacHamster,

    Thanks again for your fast answer. I will do the cleaning, replace the hard drive, and come back with the results.

    Kind regards,

    Dominic
    0

    domajean
    View Public Profile
    Find More Posts by domajean
    Add domajean to Your Contacts

    Today, 10:43 PM #6
    domajean
    Thread Starter
    macrumors newbie


    Join Date: Jun 2011 It wasn't the hard drive :S

    --------------------------------------------------------------------------------

    Hello,

    After a long wait, I finally got my new Hard drive.

    A Seagate Baracuda LP 2 TB...a nice update for my previous 500 GB western digital.

    I carefully cleaned the Imac, installed the new hard drive. All went fine.

    When I started the first time the Imac all was good...until one little glitch appear on the screen....but suddently, it disapeared....and I was able to continue the OSX installation, with some worries floating in my head.

    ''Ok, maybe it is just because it's a new hard drive''...this is what I was saying to myself to gain some confidence.

    The installation is finished. I have to click continue, but, sadly, I see a little glitch...a little white dot on the blue loading line. I click Continue and the multicolor circle appear...Waiting...waiting...nothing.

    I shut down the Mac. Open it again, it's loading on the white screen and....yea you guess it, it freezes.

    I shut down again, open it again, and....o wow, the Welcome video appears...I'm an happy fella....praticly celebrating my mac revival....but during the video....something happened

    That something is not good looking:



    Well, the good news are that the imac is clean and updated with a new hard drive...

    What do I do?

    Dominic

  2. #2
    My iMac(early 2008) video display glitches, hard freezes, help!

    Member Since
    Jun 16, 2011
    Posts
    5
    After some research I found that this is maybe due to the graphic card who overheated.

    It make sense because it was an hot day and my mac was on for 3 days in a row with some little brakes between, but not enough.

    I finally got to the desktop, tried smcfans control and glitches appeared after a little while.

    According to the other forums it is praticly impossible to change the graphic card or the mother board.

    If anybody have a solution or anything...

    Thanks.

    Dominic

  3. #3
    My iMac(early 2008) video display glitches, hard freezes, help!
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,262
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    Everything I read in your posts point to a malfunctioning GPU. When you opened the iMac, was the GPU fan operating normally? And are you measuring the temperatures? If the GPU fan is not working, that will cause the system to freeze and possibly cause the color and white splotches you see on the screen.

    As you mentioned, you can not swap out the GPU in that machine. It would have to be the entire logic board that needs to be changed.

  4. #4
    My iMac(early 2008) video display glitches, hard freezes, help!

    Member Since
    Jun 16, 2011
    Posts
    5
    Hello chscag,

    Thanks a lot for your answer.

    Now that you mention this, when I tested smcfancontrol I wasn't hearing much...or praticly anything even with my ear really close to the imac.

    I will find a way to measure the temperatures and I will try to know if the fans are working correctly and come back with the results.

    Thanks again!

    Dominic

    **IMPORTANT EDIT**

    I checked my imac specs and i have the optional video card:

    Nvidia Geforce 8800 GS

    Which is known to have problems after 2-3 years of use...overheating, which cause artifacts and freezes:

    http://forums.macrumors.com/showthread.php?t=1085213

    I'm doomed

  5. #5
    My iMac(early 2008) video display glitches, hard freezes, help!

    Member Since
    Jun 16, 2011
    Posts
    5
    A little mistake from me...
    Oups...I just checked the specs of my imac...

    My graphic card is an Nvidia Geforce 8800 GS.
    Sorry for that, I was sure I had the ATI standard one.

    So I installed a temperature measuring software, and here are the results:

    After 5 minutes:



    After 10 minutes(getting more hot):



    After 15 minutes(the mac is frozen, nothing work, and it's more hot)



    Maybe like you say the fans don't work properly...?

    Let me know what are your thought and if someone else have some advices to solve this issue don't hesitate to add your thoughts.

    Thanks for your next responses.

    Dominic

  6. #6
    My iMac(early 2008) video display glitches, hard freezes, help!

    Member Since
    Aug 21, 2009
    Posts
    43
    Bump.

    This is happening to my 2007 macbook pro. It glitched out a few days ago for the first time, and then yesterday it went bonkers. I can't even get past the white loading screen when I turn on my laptop. It will act like it's turning on, but the apple insignia is glitchy and then it freezes. It is totally unresponsive except when I press the volume buttons I can hear the volume change. Which leads me to believe that the computer is still functioning but the screen video is unresponsive.

    I can't even check the specs on it because I can't get past the loading screen. I had no time to retrieve files or anything.

    Is my laptop totally screwed?

  7. #7
    My iMac(early 2008) video display glitches, hard freezes, help!
    baggss's Avatar
    Member Since
    Oct 10, 2004
    Location
    Margaritaville
    Posts
    10,310
    Specs:
    27" 3.4 Ghz i7 iMac-13" C2D Macbook-OSX 10.10.2 -64Gb iPad 2-64 Gb iPhone 6+-ATV 2-14Tb of Storage
    Boot the Macbook Pro from the DVD that came with it, open disc utility and run repair permissions and verify the disc. If all else fails do an Archive and Instal and reload OSX from the disc (this will move your profile to a new system folder that will be installed, your data will not be lost). You'll have to run the updater to get any new software that is out there but this is your best bet to start with.

    If the instal fails or the same issues occur after, then it is likely the HDD or the logic board.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iMac (24" Early 2008) Hard Drive troubleshooting help
    By caaalebbb in forum Apple Desktops
    Replies: 1
    Last Post: 11-10-2014, 11:32 PM
  2. display problem in mac pro early 2008
    By khanjany in forum Apple Notebooks
    Replies: 1
    Last Post: 09-21-2013, 01:42 PM
  3. LCD display issues - Early 2008 MBP Core Duo 2
    By Wayne W in forum Apple Notebooks
    Replies: 20
    Last Post: 03-28-2012, 09:47 AM
  4. Early 2008 Display Problem
    By ctjocko in forum Apple Notebooks
    Replies: 2
    Last Post: 01-29-2012, 07:15 PM
  5. Early 2008 24" Imac Video Card Upgrade
    By solywoda in forum Apple Desktops
    Replies: 2
    Last Post: 05-10-2011, 10:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •