Results 1 to 3 of 3
  1. #1
    New 2TB My Studio LX HD slowing my imac way down

    Member Since
    Dec 04, 2010
    Posts
    2
    New 2TB My Studio LX HD slowing my imac way down
    I just bought a 2TB Studio LX external HD from the Mac store in fact. Ever since I started using it last week my imac is almost not usable its so slow. Almost every time I try to even move my mouse or click on something I get the pinwheel. I turned it off and things seem to be much better. Not sure why this would be as there are only about 600gb of files on it so far and Im using my firewire port. Ive ran my disk utility and done a disk repair and have used Onyx to try what I could think of. I even removed istat pro and symantec but the thing that helped the most was just turning the hd off. How can I use this new HD while still getting my imac to work?
    Thanks

  2. #2
    New 2TB My Studio LX HD slowing my imac way down
    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,758
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    Quote Originally Posted by ak6143 View Post
    I even removed istat pro and symantec but the thing that helped the most was just turning the hd off. How can I use this new HD while still getting my imac to work?
    Thanks
    I suspect that's your problem right there. Are you sure it's completely gone? Symantec goes pretty deep and it's known to be horribly difficult to remove.

    Quite honestly, the cure is worse than the (non-existent) disease in the case of Symantec.

    Also, I would disable Spotlight indexing on the external. Open System Preferences => Spotlight. Click the Privacy tab and then drag the external's icon into the list. See if that makes a difference.
    Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!

    https://youtu.be/KHZ8ek-6ccc

  3. #3
    New 2TB My Studio LX HD slowing my imac way down

    Member Since
    Dec 04, 2010
    Posts
    2
    Im not 100% sure I got Symantec off all the way or that I know how but I did that part 2 days ago and it was still terrible trying to use the computer but when I shut the HD off this morning its been working great. Ill try changing that preference but if there are any other suggestions Im certainly greatful.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with my Segate 2TB drive and Imac
    By peterfc in forum Switcher Hangout
    Replies: 2
    Last Post: 07-14-2014, 02:45 PM
  2. Replies: 12
    Last Post: 08-24-2011, 05:35 PM
  3. Backup strategy for 2TB iMac
    By torrit in forum Apple Desktops
    Replies: 5
    Last Post: 05-27-2011, 08:46 AM
  4. Does my iMac support 2TB Hard Drive?
    By Narpstar in forum Apple Desktops
    Replies: 4
    Last Post: 01-16-2011, 12:10 AM
  5. New 27" iMac, do I need 2TB HD?
    By SmallvilleGirl in forum Apple Desktops
    Replies: 4
    Last Post: 09-21-2010, 12:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •