Results 1 to 4 of 4
  1. #1
    G3 DV400 No Display Problem

    Member Since
    May 20, 2009
    Posts
    3
    Unhappy G3 DV400 No Display Problem
    Hey there,

    i just got a iMac G3 DV400 Grape from one of my friends. (M5521 i think)

    It had OS 9.2 on it, and i wanted to use it with tiger.

    Before installing tiger, I replaced its 10gigs hard drive with a 40gigs hd. I've done this with the guide from Replace the Hard Drive on a G3 iMac (iMac G3 DV)

    Anyway, after replacing the hard drive, I turned on the mac, heard the opening sound but... No display. HDD and the other things spin, but that's all.

    I immediately put the old drive back on but no change. The situation remains the same.

    Fyi, while changing the hdd, I unplugged the powercable.

    Any opinions? Right now, the iMac is open. No display, I'm not sure if it's working but the CRT is not, or it's not just the display, also the whole system too. All i can hear is spinning hdd and the other little noises from the system.

    Thanks in advance.

  2. #2
    G3 DV400 No Display Problem
    x slurm x's Avatar
    Member Since
    May 11, 2009
    Location
    Kentucky
    Posts
    17
    Specs:
    Early '08 MacBook 2.4Ghz 250g hd 4g ram Os 10.6; B&W G3 400mhz 120g hd 512mb ram Os 10.4
    I've sometimes noticed that when I've changed something inside the my G3, it may not properly boot the first time afterward, so trying a couple of times may help. Also I usually try to remember to reset the pRam if I change anything. This is done by holding command, option, p, and r immediately after turning the machine on. Not that it would be a problem yet, but you may want to check the Tiger system requirements to make sure you have enough ram. I think you can max out the ram on a G3 (1gb) for around 30-40$ on eBay. Just a suggestion.
    Good luck!

  3. #3
    G3 DV400 No Display Problem
    Mac SK's Avatar
    Member Since
    Oct 20, 2006
    Posts
    1,513
    Make shure you pluged every thing in right and that the memory sticks are seatted. When you replace a hard drive you lose the firmwear for the Imac. The boot rom must be 4.1.9 before you install Ten.

  4. #4
    G3 DV400 No Display Problem

    Member Since
    May 20, 2009
    Posts
    3
    Quote Originally Posted by Mac SK View Post
    Make shure you pluged every thing in right and that the memory sticks are seatted. When you replace a hard drive you lose the firmwear for the Imac. The boot rom must be 4.1.9 before you install Ten.
    Hey,

    could the losing of firmware cause my problem?

    if so, how can i add the 4.1.9 boot rom before installing tiger?

    also,

    resetting the pRam didn't work.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Display Problem
    By vidasvarma in forum Apple Notebooks
    Replies: 5
    Last Post: 04-01-2012, 10:05 PM
  2. display problem
    By ed nalbandian in forum Apple Notebooks
    Replies: 0
    Last Post: 04-11-2010, 11:43 AM
  3. Replies: 1
    Last Post: 03-16-2005, 12:50 AM
  4. iMac dv400 booting up issues
    By striderhanzo in forum Apple Desktops
    Replies: 1
    Last Post: 01-12-2005, 10:45 PM
  5. Max Ram for dv400 imac?
    By Texasmeat in forum Apple Desktops
    Replies: 1
    Last Post: 03-24-2004, 11:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •